Problem after install of libbxml2 and ionCube

Talk about anything that doesn't fit in the other catagories :) (and of course is about Group-Office)

Moderator: Developers

wanderson
Posts: 2
Joined: Thu May 01, 2014 5:16 pm

Problem after install of libbxml2 and ionCube

Postby wanderson » Thu May 01, 2014 5:39 pm

I have just installed latest Group-Office community edition on clean and tested Debian Wheezy 7.5.

After completing basic installation and bringing up group-Office on web page, I was notified of following three (3) missing files to make Group-Office function properly. The website did indicate that "group-office would run"

1. pspell
2. libwbxml2
3. ionCube

I installed all three (3) via apt-get, which registered success but still got warning of No2 and No3 NOT installed.

Questions:
a. Do I need to install lebwbxml2-DEV (developer)?

b. I entered script line "zend_extension = ..." in php.ini file, using ionCube loader bin "5.4" to match PHP5 5.4 version installed, and inserted under php.ini section "Paths and Directories".
I also changed permissions to 666 on /etc/...config.php.

Any help in resolving configuration of these two applications (No2 and No3) would be very helpful and appreciated

Wendell Anderson
wanderson@kimalcorp.org
richarddodd
Posts: 66
Joined: Fri Jun 21, 2013 2:55 pm

Re: Problem after install of libbxml2 and ionCube

Postby richarddodd » Fri May 02, 2014 8:37 am

I've never found ioncube in the apt repository - I've always grabbed it from the vendor website. Wbxml is used for activesync (stands for binary xml), you might need to get the package libwbxml2-utils, which has the actual binarys in it.
wanderson
Posts: 2
Joined: Thu May 01, 2014 5:16 pm

Re: Problem after install of libbxml2 and ionCube

Postby wanderson » Mon May 05, 2014 5:32 pm

Thanks for libwbxml2 info, it worked. I apologize for stating install of ionCube via apt-get as I was not thinking clearly at that time. I still get error of "not installed" for ionCube, even though I downloaded targz files, folloed all procedures for install and setup - with any error messages on install and configure procedure, but still receive not installed message on Groupoffice statup screen.

Can you and anyone help with that last step - and if according to my previous stated steps for ionCube.
richarddodd
Posts: 66
Joined: Fri Jun 21, 2013 2:55 pm

Re: Problem after install of libbxml2 and ionCube

Postby richarddodd » Tue May 06, 2014 9:07 am

Sometimes you don't want to use the latest version of ioncube, so it's worth trying the second newest version. Also, when you do `php -v`, does it show "with the ioncube loader" on the command line?

Who is online

Users browsing this forum: No registered users and 4 guests