GroupOffice Webdav Office Uploads failing

Talk about anything that doesn't fit in the other catagories :) (and of course is about Group-Office)

Moderator: Developers

certgo
Posts: 5
Joined: Tue Oct 07, 2014 8:28 am

GroupOffice Webdav Office Uploads failing

Postby certgo » Mon Oct 26, 2015 11:01 am

Hi,

I have GroupOffice 5.0.107 on an Ubuntu 14.04 LTS, installed using the "GroupOffice Complete Mailserver" solution. I setup webdav support according to https://www.group-office.com/wiki/WebDAV. On the client side I have Windows 10 and Office 2016.

The whole setup has been working very well for almost a year, but in the past few days Office files will no longer save back to webdav once opened (i.e. double click to open in file manager, type some text, click "Save and Refresh with updates").

Microsoft Office Upload Center gives the error message "Upload Failed / Upload error".

Looking in the Apache access.log I see the following sequence when opening and saving a file:
    * >>>> Open <<<<
    * LOCK 401
    * LOCK 200
    * GET 401
    * GET 200
    * >>>> Save <<<<
    * LOCK 401
    * LOCK 200
    * PUT 401 <- fails here

The only thing that has changed is that GroupOffice was updated via the Ubuntu apt repository updates about the time I started to see this problem. It is also possible that Office was updated (automatic updates are on).

I am a bit lost where to look for an answer, mostly because ever since installing this has all "just worked"!

TIA for any help.
certgo
Posts: 5
Joined: Tue Oct 07, 2014 8:28 am

[SOLVED] Re: GroupOffice Webdav Office Uploads failing

Postby certgo » Tue Nov 03, 2015 9:08 pm

Sorry, this appears to be unrelated to Group-Office and sabre-dav.

Rolling back to an old version of Office seems to fix the problem, see here http://www.msoutlook.info/question/784 and possibly even repairing the current version may also work.

Return to “GroupOffice main discussion”

Who is online

Users browsing this forum: No registered users and 2 guests