Unknown Content-type

Talk about anything that doesn't fit in the other catagories :) (and of course is about Group-Office)

Moderator: Developers

lukpln
Posts: 2
Joined: Tue Jul 12, 2016 7:28 am

Unknown Content-type

Postby lukpln » Tue Jul 12, 2016 10:54 am

Hi.

from few senders I get mails with strange headers, i.e.:

Code: Select all

Return-Path: <mailing@oferent.com.pl>
Received: from mx4.gbp.pl (91.208.44.234) (HELO mx4.gbp.pl)
 by plan.home.pl (79.96.46.55) with SMTP (IdeaSmtpServer v0.80.2)
 id f7130bce86082296; Mon, 11 Jul 2016 19:45:38 +0200
Received: (qmail 4711 invoked from network); 11 Jul 2016 17:45:38 -0000
Received: from unknown (HELO ?127.0.0.1?) (of?mailing@10.1.5.108)
  by mail.biznes-europa.pl with SMTP; 11 Jul 2016 17:45:38 -0000
MIME-Version: 1.0
Content-Transfer-Encoding: 8bit
Message-ID: <1468259138.190087@oferent.com.pl>
Date: Mon, 11 Jul 2016 19:45:38 +0200
From: =?utf-8?q?Oferent=2Ecom=2Epl?= <mailing@oferent.com.pl>
To: =?utf-8?q?a=2Edebska=40plan=2Epl?= <a.debska@plan.pl>
Subject: =?utf-8?q?Przetargi_z_dnia_2016-07-11_dla_konta_115733?=
Content-Type: text/html; charset="utf-8"; type="text/html"


When message has:

Code: Select all

Content-Transfer-Encoding: 8bit


Then whole message body with html tag will be pushed to attachment with out file extension.
I tried to add those headers to ./go/base/mail/MimeDecode.php but still it dosnt resolve this issue.

Below whole message source:

Code: Select all

Return-Path: <mailing@oferent.com.pl>
Received: from mx4.gbp.pl (91.208.44.234) (HELO mx4.gbp.pl)
 by plan.home.pl (79.96.46.55) with SMTP (IdeaSmtpServer v0.80.2)
 id f7130bce86082296; Mon, 11 Jul 2016 19:45:38 +0200
Received: (qmail 4711 invoked from network); 11 Jul 2016 17:45:38 -0000
Received: from unknown (HELO ?127.0.0.1?) (of?mailing@10.1.5.108)
  by mail.biznes-europa.pl with SMTP; 11 Jul 2016 17:45:38 -0000
MIME-Version: 1.0
Content-Transfer-Encoding: 8bit
Message-ID: <1468259138.190087@oferent.com.pl>
Date: Mon, 11 Jul 2016 19:45:38 +0200
From: =?utf-8?q?Oferent=2Ecom=2Epl?= <mailing@oferent.com.pl>
To: =?utf-8?q?a=2Edebska=40plan=2Epl?= <a.debska@plan.pl>
Subject: =?utf-8?q?Przetargi_z_dnia_2016-07-11_dla_konta_115733?=
Content-Type: text/html; charset="utf-8"; type="text/html"


<html>
<head>
<meta charset="utf-8">
<title>Raport przetargowy Oferent.com.pl z dnia 2016-07-11 dla konta nr 115733</title>
<style>
    table{
        font-family: 'Arial', sans-serif; font-size: 12px;
    }
    table a:visited{
        color: #919191 !important;
    }
    a:focus{
        outline: 0;
    }
</style>
</head>
<body style="text-align:center; background-color:#f0f0f0; font-family:Arial, sans-serif; font-size: 12px;">
    <table width="766" cellpadding="0" cellspacing="0" border="0" style="margin:0 auto;background-color:#fff; font-size: 12px; border:solid 1px #e4e4e4; border-bottom:solid 2px #cccccc;text-align:left;">
   
   <tr>
   <td>
   Here goes message content.
   </td>
   </tr>
   
    </table>
</body>
</html>


So my question is: In what file I should define the missing headers?

Return to “GroupOffice main discussion”

Who is online

Users browsing this forum: No registered users and 5 guests