[Fixed] IMAP subscribe to public namespace folders

Talk about anything that doesn't fit in the other catagories :) (and of course is about Group-Office)

Moderator: Developers

certadmin
Posts: 10
Joined: Mon Sep 13, 2010 10:29 am

[Fixed] IMAP subscribe to public namespace folders

Postby certadmin » Mon Sep 13, 2010 10:53 am

I am evaluating version 3.5.23 of GroupOffice community.

We are using a Dovecot IMAP server with public namespaces to provide shared mailboxes, for example:

Company
-->Accounts
-->Marketing
-->Sales
-->Engineering
-->-->Development
-->-->Testing

Within other IMAP clients (Thunderbird, Windows Mail, Outlook) everything works fine.

In Group-Office, although all the subscribed mailboxes are being shown in the "manage folder" list, they are not being shown in the correct tree structure and in the main account window only a few of the subscriptions are being displayed.

As a check I tried to connect to our old setup on a Cyrus server and met with the same problem, so I guess this is a Group-Office error (or my misunderstanding).
Last edited by certadmin on Sat Jan 22, 2011 9:59 am, edited 1 time in total.
certadmin
Posts: 10
Joined: Mon Sep 13, 2010 10:29 am

Re: IMAP subscribe to public namespace folders

Postby certadmin » Thu Oct 14, 2010 9:31 pm

For anyone experiencing the same problem, I think I have found a work-around.

I am not an expert on IMAP or Dovecot, so please forgive me if I have used incorrect terminology.

It appears that GO requires that "root" folders to have no parent. This is intuitively true for private folders but is not true for shared folders (at least for Dovecot IMAP).

To follow my previous example....

Company
-->Accounts
-->Marketing
-->Sales
-->Engineering
-->-->Development
-->-->Testing

"Accounts" is a child of "Company" but for shared folders "Company" is not a folder but a namespace. In the Dovecot Maildir this will appear as...

.Accounts
.Marketing
.Sales
.Engineering
.Engineering.Development
.Engineering.Testing

None of these folders are visible in Group-Office (even if they are subscribed) because they all have a "parent".

The workaround is to prefix all entries in the Company maildir with .Company as follows:

.Company.Accounts
.Company.Marketing
.Company.Sales
.Company.Engineering
.Company.Engineering.Development
.Company.Engineering.Testing

Because there is no ".Company" all the folders appear to be orphans, and GO treats these as root folders and displays them perfectly! Of course in any other IMAP client you will see an additional "Company" as the root folder like this....

Company
-->Company
-->-->Accounts
-->-->Marketing
-->-->Sales
-->-->Engineering
-->-->-->Development
-->-->-->Testing

... but at least the road warriors can access their email :D
mschering
Site Admin
Site Admin
Posts: 8339
Joined: Tue Apr 20, 2004 1:06 pm
Location: The Netherlands - Den Bosch
Contact:

Re: IMAP subscribe to public namespace folders

Postby mschering » Fri Oct 15, 2010 7:16 am

Did you set a root mailbox in the mail properties?
Best regards,

Merijn Schering
Intermesh
certadmin
Posts: 10
Joined: Mon Sep 13, 2010 10:29 am

Re: IMAP subscribe to public namespace folders

Postby certadmin » Tue Oct 19, 2010 10:39 pm

Hi, thank you for your reply and sorry for my slow response.

Yes, I tried various combinations in the "Root mailbox" setting (under Administration->Accounts), but with little difference.

Our mailbox is setup like this:

/home/vmail/company = holds all shared folders
/home/vmail/company.com = holds individual user accounts (virtual users)

If I enter "company" in Root mailbox then all the folders disappear, even in the Manage Folders screen.

Any other value in Root mailbox does not appear to get stored, next time you open the dialog the value is lost.

With an empty Root mailbox setting, all the folders appear in the Manage folders (subscribe) screen, but no matter what you select they do not appear in the user account folder list.
mschering
Site Admin
Site Admin
Posts: 8339
Joined: Tue Apr 20, 2004 1:06 pm
Location: The Netherlands - Den Bosch
Contact:

Re: IMAP subscribe to public namespace folders

Postby mschering » Wed Oct 20, 2010 7:45 am

Can you setup a test imap account for me and send me the details. It should have a shared folder too.
Best regards,

Merijn Schering
Intermesh
certadmin
Posts: 10
Joined: Mon Sep 13, 2010 10:29 am

Re: IMAP subscribe to public namespace folders

Postby certadmin » Thu Oct 21, 2010 2:32 pm

Thank you for your help. I have sent you a PM with the test account details.
certadmin
Posts: 10
Joined: Mon Sep 13, 2010 10:29 am

Re: IMAP subscribe to public namespace folders

Postby certadmin » Wed Dec 22, 2010 2:04 pm

@intermesh

Did you ever get a chance to test this problem? Is there another way I can help with a solution?

Many thanks!
mschering
Site Admin
Site Admin
Posts: 8339
Joined: Tue Apr 20, 2004 1:06 pm
Location: The Netherlands - Den Bosch
Contact:

Re: IMAP subscribe to public namespace folders

Postby mschering » Wed Dec 29, 2010 9:50 am

Sorry it took so long. I finally fixed this. It will be in the next release.
Best regards,

Merijn Schering
Intermesh
certadmin
Posts: 10
Joined: Mon Sep 13, 2010 10:29 am

Re: IMAP subscribe to public namespace folders

Postby certadmin » Tue Jan 18, 2011 9:21 am

That is excellent news, many thanks!!!!

Sorry for the late post, I forgot to turn on notifications.

Who is online

Users browsing this forum: No registered users and 5 guests

cron