Problem with adding Bookmarks

Talk about anything that doesn't fit in the other catagories :) (and of course is about Group-Office)

Moderator: Developers

soldier99
Posts: 14
Joined: Mon Apr 26, 2010 5:33 pm

Problem with adding Bookmarks

Postby soldier99 » Tue Dec 07, 2010 12:48 pm

Hi!

I like a lot this bookmark feature, but somehow when i want to add it, I get an error:
"Warning: curl_setopt() [function.curl-setopt]: CURLOPT_FOLLOWLOCATION cannot be activated when safe_mode is enabled or an open_basedir is set in /home/username/domains/yoursite.com/public_html/goffice/modules/bookmarks/json.php on line 43

{"description":"","title":"301 Moved Permanently"}"

What should I do to fix the problem?
mschering
Site Admin
Site Admin
Posts: 8339
Joined: Tue Apr 20, 2004 1:06 pm
Location: The Netherlands - Den Bosch
Contact:

Re: Problem with adding Bookmarks

Postby mschering » Tue Dec 07, 2010 4:14 pm

Apperntly it doesn't work with safe_mode enabled. Perhaps you should disable display_errors in php.ini.
Best regards,

Merijn Schering
Intermesh
User avatar
lonesomewalker
Posts: 320
Joined: Wed Sep 15, 2004 9:15 am
Location: everywhere
Contact:

Re: Problem with adding Bookmarks

Postby lonesomewalker » Wed Dec 08, 2010 11:43 am

Unfortunately, i have a client, which can't upload files for the same reason.
Already opened a ticket, because of PRO edition.

Has never had any troubles before, and he also has safe mode off.

open_basedir is set, because it is better to have it, than have nothing ;-)
mschering
Site Admin
Site Admin
Posts: 8339
Joined: Tue Apr 20, 2004 1:06 pm
Location: The Netherlands - Den Bosch
Contact:

Re: Problem with adding Bookmarks

Postby mschering » Wed Dec 08, 2010 2:59 pm

We discovered that it doesn't work with self signed ssl certificates:

There are some workarounds: http://swfupload.org/forum/generaldiscussion/347

IN the nextr version we will also add and $config['disable_flash_upload']=true; option to disable it.
Best regards,

Merijn Schering
Intermesh
User avatar
lonesomewalker
Posts: 320
Joined: Wed Sep 15, 2004 9:15 am
Location: everywhere
Contact:

Re: Problem with adding Bookmarks

Postby lonesomewalker » Wed Dec 08, 2010 7:40 pm

Erm, at my installation there is NO ssl certificate :(

But good to know that this is just an option to deactivate.
mschering
Site Admin
Site Admin
Posts: 8339
Joined: Tue Apr 20, 2004 1:06 pm
Location: The Netherlands - Den Bosch
Contact:

Re: Problem with adding Bookmarks

Postby mschering » Thu Dec 09, 2010 8:03 am

Do you have other restrictions set up in regard to session handling?
Best regards,

Merijn Schering
Intermesh
User avatar
lonesomewalker
Posts: 320
Joined: Wed Sep 15, 2004 9:15 am
Location: everywhere
Contact:

Re: Problem with adding Bookmarks

Postby lonesomewalker » Thu Dec 09, 2010 12:59 pm

Nope.
I say, sessions must be written to a special path due the fact of open_basedir.
Please no comments about this broken security-thingy.
We know that all, but one hurdle more in the path of a hacker is one more.
Nevertheless, the include path is in this case pretty full, so i expect NO problems from open_basedir.
soldier99
Posts: 14
Joined: Mon Apr 26, 2010 5:33 pm

Re: Problem with adding Bookmarks

Postby soldier99 » Thu Dec 09, 2010 4:15 pm

Intermesh wrote:Apperntly it doesn't work with safe_mode enabled. Perhaps you should disable display_errors in php.ini.
OK! Got that prblem fixed, thank you.
mschering
Site Admin
Site Admin
Posts: 8339
Joined: Tue Apr 20, 2004 1:06 pm
Location: The Netherlands - Den Bosch
Contact:

Re: Problem with adding Bookmarks

Postby mschering » Thu Dec 09, 2010 4:25 pm

@LW
Can you send me your php.ini?
Best regards,

Merijn Schering
Intermesh
User avatar
lonesomewalker
Posts: 320
Joined: Wed Sep 15, 2004 9:15 am
Location: everywhere
Contact:

Re: Problem with adding Bookmarks

Postby lonesomewalker » Thu Dec 09, 2010 6:22 pm

Will upload it in the ticket system of the customer :-)

Who is online

Users browsing this forum: No registered users and 3 guests