email composer: open attachments

Talk about anything that doesn't fit in the other catagories :) (and of course is about Group-Office)

Moderator: Developers

webwolfi
Posts: 616
Joined: Sat May 27, 2006 7:54 am
Location: Vienna/Austria

email composer: open attachments

Postby webwolfi » Fri Jun 10, 2011 7:47 pm

upgraded to 3.7.22 PRO

in email composer attachments are downloadable now (as announced), but the downloaded files seem to be corrupted.
did I anything wrong testing it or is it a small bug?

Wolfgang
rosetta
Group-Office Expert
Group-Office Expert
Posts: 546
Joined: Tue Jul 14, 2009 2:25 pm
Location: Norway
Contact:

Re: email composer: open attachments

Postby rosetta » Fri Jun 10, 2011 10:12 pm

Seems to work fine here.

Have tested with PDF and XLS files...
webwolfi
Posts: 616
Joined: Sat May 27, 2006 7:54 am
Location: Vienna/Austria

Re: email composer: open attachments

Postby webwolfi » Sat Jun 11, 2011 7:27 am

update:

the attachments (independent from the file type) downloaded directly from the composer window (eg. to control if it's the right version of a document) have 0 byte.
when I send them, they are sent correctly and can be downloaded normal from the received mail.
Windows 7 (64b) here on client side, tested with Firefox and IE
mschering
Site Admin
Site Admin
Posts: 8333
Joined: Tue Apr 20, 2004 1:06 pm
Location: The Netherlands - Den Bosch
Contact:

Re: email composer: open attachments

Postby mschering » Tue Jun 14, 2011 6:47 am

I can't replicate the error here. Do you get any errors in the log?
Best regards,

Merijn Schering
Intermesh
webwolfi
Posts: 616
Joined: Sat May 27, 2006 7:54 am
Location: Vienna/Austria

Re: email composer: open attachments

Postby webwolfi » Tue Jun 14, 2011 8:39 am

Hi Merijn,

i sent you a pm with the error log

thx Wolfgang
webwolfi
Posts: 616
Joined: Sat May 27, 2006 7:54 am
Location: Vienna/Austria

Re: email composer: open attachments

Postby webwolfi » Tue Jun 21, 2011 8:06 am

anything new on this?

@merijn got my pm or mail?
webwolfi
Posts: 616
Joined: Sat May 27, 2006 7:54 am
Location: Vienna/Austria

Re: email composer: open attachments

Postby webwolfi » Fri Jun 24, 2011 4:22 pm

update:

it works well when I add an attachment from the pc (upload).
the error occurs only when i add something from the server.

this is from the apache error log:
[Fri Jun 24 18:12:56 2011] [error] [client xxx.xxx.xxx.xxx] PHP Warning: readfile(/tmp/2/attachments/myfilename.ext) [<a href='function.readfile'>function.readfile</a>]: No such file or directory in /path/to/my/installation/modules/email/download_file.php on line 32, referer: http://my.go.url/index.php
seems that it searches something in the tmp files which isn't copied there, when adding a file from the server

any hint?

Wolfgang
rosetta
Group-Office Expert
Group-Office Expert
Posts: 546
Joined: Tue Jul 14, 2009 2:25 pm
Location: Norway
Contact:

Re: email composer: open attachments

Postby rosetta » Fri Jun 24, 2011 4:52 pm

I can confirm this bug.

When attaching a file from GO (not from PC) it is not possible to download it from the email composer.
mschering
Site Admin
Site Admin
Posts: 8333
Joined: Tue Apr 20, 2004 1:06 pm
Location: The Netherlands - Den Bosch
Contact:

Re: email composer: open attachments

Postby mschering » Sat Jul 09, 2011 7:16 pm

Thx, we'll look into this bug.
Best regards,

Merijn Schering
Intermesh
mschering
Site Admin
Site Admin
Posts: 8333
Joined: Tue Apr 20, 2004 1:06 pm
Location: The Netherlands - Den Bosch
Contact:

Re: email composer: open attachments

Postby mschering » Mon Jul 25, 2011 11:44 am

Will be fixed in 3.7.25
Best regards,

Merijn Schering
Intermesh

Who is online

Users browsing this forum: No registered users and 1 guest