Group-Office 2.14-FC Released

Read important announcements about Group-Office here

Moderator: Developers

angelodi
Posts: 145
Joined: Fri Apr 23, 2004 7:05 am

Postby angelodi » Tue Oct 18, 2005 9:31 am

Is there a description for the new development toolkit? How can i use it and can create own Modules for Group Office?

Regards Angelo
guest

Postby guest » Tue Oct 18, 2005 9:32 am

angelodi wrote:This happens after call "Adressbook install". After that i see the Adressbook as installed, but a click on the Adressbook icon creates another errors, because no tables was created.

Then i tried to deinstall the adressbook and install again, but i get the same error.


Open the file /modules/addressbook/sql/addressbook.install.sql and remove the last quote:

DROP TABLE IF EXISTS `ab_addressbooks`;
CREATE TABLE `ab_addressbooks` (
`id` int(11) NOT NULL default '0',
`user_id` int(11) NOT NULL default '0',
`name` varchar(50) NOT NULL default '',
`acl_read` int(11) NOT NULL default '0',
`acl_write` int(11) NOT NULL default '0',
PRIMARY KEY (`id`),
KEY `user_id` (`user_id`)
) TYPE=MyISAM;"
User avatar
EnjoyRC
Posts: 26
Joined: Sun May 08, 2005 7:45 pm
Location: St. Louis MO USA
Contact:

Postby EnjoyRC » Tue Oct 18, 2005 11:56 am

Intermesh wrote:Try changing lines 35 to 27 of date/Date/Date.php into:

require_once $GO_CONFIG->class_path.'date/Date/TimeZone.php';
require_once $GO_CONFIG->class_path.'date/Date/Calc.php';
require_once $GO_CONFIG->class_path.'date/Date/Span.php';

Fixed it... thanks for your efforts.
User avatar
dkittell
Site Admin
Site Admin
Posts: 808
Joined: Tue May 25, 2004 10:32 pm
Location: Michigan, USA
Contact:

Postby dkittell » Wed Oct 19, 2005 9:10 pm

Finally got off my butt and upgraded to the latest build.
Install process looks great.
David Kittell
Owner / Developer
Kittell.net

Return to “Announcements”

Who is online

Users browsing this forum: No registered users and 1 guest

cron