New users/user groups not visible

Read important announcements about Group-Office here

Moderator: Developers

sonnieboy
Posts: 3
Joined: Mon Jan 21, 2008 9:17 pm

New users/user groups not visible

Postby sonnieboy » Thu May 13, 2010 5:52 pm

Hi,

using GO 3.4.14 and come form an upgrade from 2.18 to 2.19 and then 3.4.14.
Everything seemed to working just fine.

Problem:
Created a new user and added this to new user group.
This new user (and the new group) is not listed in the existing groups and users when I want to give them sharing premissions for a folder.
Not all the existing groups and users are listed when I want to select a user or group (from a user).
Already tried "Database check" and "Create search index" from Admin tools, but without succes.

Any ideas or help?

John
mschering
Site Admin
Site Admin
Posts: 8154
Joined: Tue Apr 20, 2004 1:06 pm
Location: The Netherlands - Den Bosch
Contact:

Re: New users/user groups not visible

Postby mschering » Thu May 13, 2010 6:06 pm

Maybe the user setting up the permissions is not allowed to see the user you just added. At the permissions tab of the user profile you can control who's allowed to see the user.
Best regards,

Merijn Schering
Intermesh
albarreto
Posts: 22
Joined: Tue Aug 10, 2010 6:48 pm

Re: New users/user groups not visible

Postby albarreto » Tue Aug 17, 2010 1:32 pm

Is it possible ALL new users/groups to be visible for all?
It's boring to change each user permissions.

GO 3.5.21
mschering
Site Admin
Site Admin
Posts: 8154
Joined: Tue Apr 20, 2004 1:06 pm
Location: The Netherlands - Den Bosch
Contact:

Re: New users/user groups not visible

Postby mschering » Thu Aug 19, 2010 7:04 am

You can modify the default setting in config.php:

$config['visible_groups']='Everyone';

But existing users have to be modified one by one.
Best regards,



Merijn Schering

Intermesh
albarreto
Posts: 22
Joined: Tue Aug 10, 2010 6:48 pm

Re: New users/user groups not visible

Postby albarreto » Thu Aug 19, 2010 11:40 am

I can't see this config variable.
I see 'register_user_groups'] and 'register_visible_user_groups'.
What's the objective each one?
mschering
Site Admin
Site Admin
Posts: 8154
Joined: Tue Apr 20, 2004 1:06 pm
Location: The Netherlands - Den Bosch
Contact:

Re: New users/user groups not visible

Postby mschering » Thu Aug 19, 2010 2:19 pm

register_visible_groups are the default visible groups and the other one is for the default group membership.
Best regards,



Merijn Schering

Intermesh
albarreto
Posts: 22
Joined: Tue Aug 10, 2010 6:48 pm

Re: New users/user groups not visible

Postby albarreto » Thu Aug 18, 2011 1:33 pm

Hi again,

The problem remains!

We use a brazilian portuguese version here.
I tried various option, without success.
In table "go_groups", there's no "Everyone", but "Todos". That word in our language.

$config['register_user_groups']="Everyone,everyone,Todos";
$config['register_visible_user_groups']="Everyone,everyone,Todos";
$config['register_visible_groups']='Everyone,everyone,Todos';
$config['visible_groups']='Everyone,everyone,Todos';
mschering
Site Admin
Site Admin
Posts: 8154
Joined: Tue Apr 20, 2004 1:06 pm
Location: The Netherlands - Den Bosch
Contact:

Re: New users/user groups not visible

Postby mschering » Fri Aug 26, 2011 8:20 am

Then you should just enter "Todos" in that value.
Best regards,



Merijn Schering

Intermesh
albarreto
Posts: 22
Joined: Tue Aug 10, 2010 6:48 pm

Re: New users/user groups not visible

Postby albarreto » Fri Aug 26, 2011 11:22 am

I changed to:
$config['register_user_groups']="Todos";
$config['register_visible_user_groups']="Todos";
$config['register_visible_groups']='Todos';
$config['visible_groups']='Todos';

But the problem remains for new users... :-/

go-todos.gif
go-todos.gif (34.93 KiB) Viewed 8456 times
mschering
Site Admin
Site Admin
Posts: 8154
Joined: Tue Apr 20, 2004 1:06 pm
Location: The Netherlands - Den Bosch
Contact:

Re: New users/user groups not visible

Postby mschering » Sun Aug 28, 2011 6:53 pm

The only line you need is:

$config['register_visible_user_groups']="Todos";

This should definitely work.
Best regards,



Merijn Schering

Intermesh
albarreto
Posts: 22
Joined: Tue Aug 10, 2010 6:48 pm

Re: New users/user groups not visible

Postby albarreto » Mon Aug 29, 2011 4:55 pm

Unfortunately, your tip didn't work for us.
New users remains "todos" unchecked.

Any idea?
mschering
Site Admin
Site Admin
Posts: 8154
Joined: Tue Apr 20, 2004 1:06 pm
Location: The Netherlands - Den Bosch
Contact:

Re: New users/user groups not visible

Postby mschering » Wed Aug 31, 2011 7:08 am

I've just double checked this and it works on 3.7.27. Are you sure you don't have a duplicate config.php file and you're editing the wrong one?
Best regards,



Merijn Schering

Intermesh
albarreto
Posts: 22
Joined: Tue Aug 10, 2010 6:48 pm

Re: New users/user groups not visible

Postby albarreto » Wed Aug 31, 2011 11:04 am

There's only one config file (see image)
I uploaded my config.php for your analysis.
TIA
Attachments
config.php
(3.49 KiB) Downloaded 335 times
folder.png
folder.png (56.01 KiB) Viewed 8424 times
mschering
Site Admin
Site Admin
Posts: 8154
Joined: Tue Apr 20, 2004 1:06 pm
Location: The Netherlands - Den Bosch
Contact:

Re: New users/user groups not visible

Postby mschering » Fri Sep 02, 2011 2:34 pm

I see youy are using ldap. Are you also using an imapauth.config.php file? There you can set the groups too:

Code: Select all

$config[] =
   array(
   'proto' => 'imap',
   'domains' => '*',
   'host' => 'localhost',
   'port' => '143',
   'ssl' => false,
   'novalidate_cert' => false,
   'mbroot' => '',//you might have to change this to INBOX
   'remove_domain_from_username' => false,
   'create_email_account' => true,
   'groups' => array('Internal'),
   'visible_groups' => array('Everyone', 'Internal'),
   'modules_read' => array('email', 'files', 'addressbook', 'calendar', 'tasks', 'notes', 'summary'),
   'modules_write' => array(),

   'smtp_host'=>'localhost',
   'smtp_port'=>'25',
   'smtp_encryption'=>'',
   'smtp_username'=>'',
   'smtp_password'=>'',
   'smtp_use_login_credentials'=>true, //set to true to use the login username and password for SMTP authentication too.

   'ldap_use_email_as_imap_username'=>false,
   'imapauth_combo_domains' => 'intermesh.dev',
   'imapauth_default_domain' => 'intermesh.dev'
   );
Best regards,



Merijn Schering

Intermesh
albarreto
Posts: 22
Joined: Tue Aug 10, 2010 6:48 pm

Re: New users/user groups not visible

Postby albarreto » Fri Sep 02, 2011 4:46 pm

YES! :lol:

Solution:
'visible_groups' => array('Todos', 'Everyone', 'Internal'),

Thank you so much!

Return to “Announcements”

Who is online

Users browsing this forum: No registered users and 3 guests

cron