6.4.100 installation

Having trouble installing Group-Office? No worries. Help is on the way.

Moderator: Developers

heidi@sqcoy.fi
Posts: 4
Joined: Fri Dec 09, 2016 10:01 am

6.4.100 installation

Postby heidi@sqcoy.fi » Mon Jan 13, 2020 11:35 am

I tried to install latest 6.4.100 (7.1) Group-office on WAMP server. The installation goes through, but after that it always ask for a new installation and not showing login screen. I managed to install some older version (6.4.xxx), unfortunately I don't remember the exact version.
gianlucabonetti
Posts: 4
Joined: Wed Jan 15, 2020 11:48 am

Re: 6.4.100 installation

Postby gianlucabonetti » Wed Jan 15, 2020 11:56 am

Hello

I confirm the same behaviour on Linux Debian 9 + Apache 2.4.25 + PHP 7.0.33 + MariaDB 10.1.41 (all debian packages updated to latest version)

My installation actually was pre-existing, and it stopped working on 01/01/2020
No automated action was done, apart from standard security packages upgrades when required.
No automated action was scheduled for that time, GroupOffice just stopped working, I suppose because of packages upgrades.

Then I both tried upgrades with existing database and fresh new installs with empty database, but they both failed.
There are no errors in the logs, the software keep falling back to the installation page.

Using Group Office since may years, I had to stop because of this and fall back to another email client.
Pity.

Cheers
Gianluca
heidi@sqcoy.fi
Posts: 4
Joined: Fri Dec 09, 2016 10:01 am

Re: 6.4.100 installation

Postby heidi@sqcoy.fi » Tue Jan 21, 2020 1:38 pm

Hello

thanks for your reply Gianluca

it seems that groupoffice-6.4.82-php-71.tar.gz is the latest version which works for me. I can't do anything but use that version.

Regards, Pekka/SQC
gianlucabonetti
Posts: 4
Joined: Wed Jan 15, 2020 11:48 am

Re: 6.4.100 installation

Postby gianlucabonetti » Tue Jan 21, 2020 9:58 pm

Hello
It used to work for me with newer versions, then it suddenly stopped.
You can have a look at Apache error.log to see if there is anything strange there, but in my case there's nothing special.
Cheers
Gianluca
gianlucabonetti
Posts: 4
Joined: Wed Jan 15, 2020 11:48 am

Re: 6.4.100 installation

Postby gianlucabonetti » Mon Jan 27, 2020 4:45 pm

Hello
I can confirm that I was finally able to upgrade to 6.4.107-php70 with the existing DB.
I had to wipe out all the installation and the files directory (which anyways I didn't use), extracted the new package, and set config.php base parameters.
This way the saved email passwords were lost, but I could set again as I have a few.
Just email passwords were lost, all other users' data was kept.
Maybe it could be more difficult with thousands of email addresses.
Cheers
Gianluca
mschering
Site Admin
Site Admin
Posts: 8354
Joined: Tue Apr 20, 2004 1:06 pm
Location: The Netherlands - Den Bosch
Contact:

Re: 6.4.100 installation

Postby mschering » Thu Jan 30, 2020 4:30 pm

The query shown here: https://groupoffice.readthedocs.io/en/latest/upgrade/debian.html#from-older-versions-than-6-3 to update pa_mailboxes should fix the password problem!
Best regards,

Merijn Schering
Intermesh

Who is online

Users browsing this forum: Google [Bot] and 3 guests