OAuth problem after update 6.4.145

Having trouble installing Group-Office? No worries. Help is on the way.

Moderator: Developers

mkokenyesi
Posts: 1
Joined: Mon Sep 14, 2020 9:40 am

OAuth problem after update 6.4.145

Postby mkokenyesi » Mon Sep 14, 2020 9:51 am

Hi,

I am using GO community 6.4.144, and if I upgrade to any later versions, my GO interface will become unavailable (just a white, empty page), and I see log messages like these (in the httpd error logs):

Code: Select all

[Fri Sep 11 15:47:10.427190 2020] [php7:notice] [pid 749] [client 192.168.0.1:37554] Error in /srv/http/groupoffice/go/core/model/OauthAccessToken.php at line 21: Interface 'Legue\\OAuth2\\Server\\Entities\\AccessTokenEntityInterface' not found, referer: https://mail.my.tld/install/upgrade.php

Code: Select all

[Fri Sep 11 15:47:29.614919 2020] [php7:notice] [pid 751] [client 192.168.0.1:37588] Error in /srv/http/groupoffice/go/core/model/OauthAccessToken.php at line 21: Interface 'Legue\\OAuth2\\Server\\Entities\\AccessTokenEntityInterface' not found
(I deliberately changed the IP and FQDN strings above, before posting)
I found that 6.4.145 is the first version using OAuth.
My GO installation is on a VM behind a reverse proxy (192.168.0.1), in case it matters.
Please help me what cause this, and how can I fix it!

Who is online

Users browsing this forum: No registered users and 5 guests

cron