Nginx Configuration

Having trouble installing Group-Office? No worries. Help is on the way.

Moderator: Developers

godmode42
Posts: 1
Joined: Thu Dec 10, 2015 7:33 am

Nginx Configuration

Postby godmode42 » Thu Dec 10, 2015 7:49 am

Is someone out there who hast a working group-office configuration with cal/carddav support, running on nginx?
My installation runs perfect, except for one small thing: I can't connect any calendar via iCal.

Here is my actual config:

Code: Select all

location / {
  dav_methods PUT DELETE MKCOL COPY MOVE;
  dav_ext_methods PROPFIND OPTIONS;
  try_files $uri $uri/ /index.php;
  rewrite ^/caldav$ /modules/caldav/calendar.php$1 redirect;
  rewrite ^/carddav$ /modules/carddav/addressbook.php$1 redirect;
  rewrite ^/.well-known/caldav/$ /modules/caldav/calendar.php$1 redirect;
  rewrite ^/.well-known/carddav$ /modules/carddav/addressbook.php$1 redirect;
  keepalive_timeout 0;
}


When I try to connect I'll get no error in the logs, but iCal says: Account name and Password can't validate (Accountname/Passwort kann nicht überprüft werden):

So here is my nginx access log file:

Code: Select all

91.65.85.87 - - [10/Dec/2015:08:28:43 +0100] "PROPFIND /.well-known/caldav HTTP/1.1" 200 2032 "-" "Mac+OS+X/10.11.1 (15B42) accountsd/113"
91.65.85.87 - - [10/Dec/2015:08:28:44 +0100] "PROPFIND / HTTP/1.1" 207 598 "-" "Mac+OS+X/10.11.1 (15B42) accountsd/113"
91.65.85.87 - - [10/Dec/2015:08:28:44 +0100] "PROPFIND /caldav/v2 HTTP/1.1" 200 2029 "-" "Mac+OS+X/10.11.1 (15B42) accountsd/113"
91.65.85.87 - - [10/Dec/2015:08:28:44 +0100] "PROPFIND /principals/users/testuser/ HTTP/1.1" 200 2032 "-" "Mac+OS+X/10.11.1 (15B42) accountsd/113"
91.65.85.87 - - [10/Dec/2015:08:28:44 +0100] "PROPFIND /principals/ HTTP/1.1" 200 2031 "-" "Mac+OS+X/10.11.1 (15B42) accountsd/113"
91.65.85.87 - - [10/Dec/2015:08:28:44 +0100] "PROPFIND /dav/principals/ HTTP/1.1" 200 2029 "-" "Mac+OS+X/10.11.1 (15B42) accountsd/113"
91.65.85.87 - - [10/Dec/2015:08:28:54 +0100] "POST /index.php?r=scanbox/scanbox/scan&security_token=caAVGk47KU2IudfynXzQ HTTP/1.1" 200 81 "http://my.domain.de/" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_1) AppleWebKit/601.2.7 (KHTML, like Gecko) Version/9.0.1 Safari/601.2.7"


The nginx error log shows no error.

I would be very pleased if someone can help me. It is really important and a change to apache is not possible for some reasons.

Return to “Installation”

Who is online

Users browsing this forum: No registered users and 3 guests

cron