No modules available

Having trouble installing Group-Office? No worries. Help is on the way.

Moderator: Developers

ade.traegler
Posts: 2
Joined: Wed Jun 27, 2018 8:04 pm

No modules available

Postby ade.traegler » Thu Jun 28, 2018 9:39 pm

I use the community edition for a long time. Now I tried to upgrade to Version 6.3.20. Installation was successful but after Login I get the messega "No modules available". I updated 6.2-versions without an problem, but never got the 6.3 Version to run (6.16, 6.18, 6.20), neither as an update for 6.2 version nor as clean installation.

PHP-Version 7.1, groupoffice installed in a subdirectory, shared hosting so error logging is not able for me.

What could I do?

Thanks for help
mschering
Site Admin
Site Admin
Posts: 8235
Joined: Tue Apr 20, 2004 1:06 pm
Location: The Netherlands - Den Bosch
Contact:

Re: No modules available

Postby mschering » Sat Jun 30, 2018 6:34 pm

Can you check if you have PHP errors in your log or perhaps javascript errors in the browser. Please post them here.
Best regards,

Merijn Schering
Intermesh
ade.traegler
Posts: 2
Joined: Wed Jun 27, 2018 8:04 pm

Re: No modules available

Postby ade.traegler » Mon Jul 02, 2018 1:02 pm

Im sorry, no php-errors. Error-reporting ist disabled in php.ini, which I can't change.
I can display php-errors for my subdomain but that showed no errors. It's said that installation was successfull. I can login to groupoffice without any problem despite "no moduels available".

Inspecting the website I get a javascript-errors in views/Extjs3-script:
script.php:1084:76 "unreachable code after return statement"
And a second error:
TypeError: json is undefined script.php:171:21
Ext.util.JSON.decode
/views/Extjs3/script.php:171:21
callback
/views/Extjs3/script.php:765:376
handleResponse
/views/Extjs3/ext/ext-all-debug.js:4661:17
handleTransactionResponse
/views/Extjs3/ext/adapter/ext/ext-base-debug.js:2327:21
asyncRequest/<
/views/Extjs3/ext/adapter/ext/ext-base-debug.js:2422:15
ggomez
Posts: 3
Joined: Wed Feb 08, 2017 10:47 pm

Re: No modules available

Postby ggomez » Wed Jul 04, 2018 4:44 pm

I use the community edition for a long time. Now I tried to upgrade to Version 6.3.20. Installation was successful but after Login I get the messega "No modules available".
Sleppy83
Posts: 8
Joined: Mon Jan 22, 2018 5:49 pm

Re: No modules available

Postby Sleppy83 » Wed Jul 11, 2018 7:43 pm

Hello,

That has helped me:
https://group-office.com/forum/viewtopic.php?f=6&t=16536

For this, however, NGINX must be installed on the server.


regards
Sleppy83
cs@kosick.co
Posts: 5
Joined: Mon Jul 09, 2018 3:26 pm

Re: No modules available

Postby cs@kosick.co » Thu Jul 12, 2018 7:12 pm

Any idea why it works with nginx but not cpanel?
mainroller
Posts: 4
Joined: Tue Jul 11, 2017 1:55 pm

Re: No modules available

Postby mainroller » Sat Jul 21, 2018 3:55 pm

Same problem here. Dont have any modules available.

I even did a clean fresh install of 6.2 and just added two users - then upgraded it to 6.3.
No errors at all during database upgrade but when I log in as admin, there are no modules available.

Same goes for a clean install of 6.3.

Shared hosting here, my tools are limited
mainroller
Posts: 4
Joined: Tue Jul 11, 2017 1:55 pm

Re: No modules available

Postby mainroller » Sun Jul 22, 2018 9:35 am

While every Version of the community edition is functioning reliable since years for me, i have trouble using 6.3 since there are no modules at all showing up. Neither upgrading our working GO, nor upgrading a clean fresh install of 6.2 or a fresh install of 6.3 helps.

PHP is 7.0

I have come across this php error:

Code: Select all

[22-Jul-2018 08:43:11 UTC] go\core\http\Exception in groupoffice/go/core/jmap/State.php at line 85: Unauthorized
I changed all the permission settings to 777 temporarily but this has no effect at all.
mainroller
Posts: 4
Joined: Tue Jul 11, 2017 1:55 pm

Re: No modules available

Postby mainroller » Mon Jul 23, 2018 1:06 pm

Did a whole new installation of 6.3 with PHP 7

No modules available. I collected the following php errors:

Code: Select all

[23-Jul-2018 13:58:29 Europe/Berlin] PHP Warning:  require_once(/GO6.3/vendor/autoload.php): failed to open stream: No such file or directory in /GO6.3/GO.php on line 3
[23-Jul-2018 13:58:29 Europe/Berlin] PHP Fatal error:  require_once(): Failed opening required '/GO6.3/vendor/autoload.php' (include_path='.:/usr/local/lib/php') in /GO6.3/GO.php on line 3
[23-Jul-2018 13:58:33 Europe/Berlin] PHP Warning:  require_once(/GO6.3/vendor/autoload.php): failed to open stream: No such file or directory in /GO6.3/GO.php on line 3
[23-Jul-2018 13:58:33 Europe/Berlin] PHP Fatal error:  require_once(): Failed opening required '/GO6.3/vendor/autoload.php' (include_path='.:/usr/local/lib/php') in /GO6.3/GO.php on line 3
[23-Jul-2018 14:00:33 Europe/Berlin] PHP Warning:  require_once(/GO6.3/vendor/autoload.php): failed to open stream: No such file or directory in /GO6.3/GO.php on line 3
[23-Jul-2018 14:00:33 Europe/Berlin] PHP Fatal error:  require_once(): Failed opening required '/GO6.3/vendor/autoload.php' (include_path='.:/usr/local/lib/php') in /GO6.3/GO.php on line 3
[23-Jul-2018 14:01:29 Europe/Berlin] PHP Warning:  require_once(/GO6.3/vendor/autoload.php): failed to open stream: No such file or directory in /GO6.3/GO.php on line 3
[23-Jul-2018 14:01:29 Europe/Berlin] PHP Fatal error:  require_once(): Failed opening required '/GO6.3/vendor/autoload.php' (include_path='.:/usr/local/lib/php') in /GO6.3/GO.php on line 3
[23-Jul-2018 14:02:33 Europe/Berlin] PHP Warning:  require_once(/GO6.3/vendor/autoload.php): failed to open stream: No such file or directory in /GO6.3/GO.php on line 3
[23-Jul-2018 14:02:33 Europe/Berlin] PHP Fatal error:  require_once(): Failed opening required '/GO6.3/vendor/autoload.php' (include_path='.:/usr/local/lib/php') in /GO6.3/GO.php on line 3
[23-Jul-2018 14:04:26 Europe/Berlin] PHP Warning:  require(/GO6.3/vendor/composer/../sabre/uri/lib/functions.php): failed to open stream: No such file or directory in /GO6.3/vendor/composer/autoload_real.php on line 66
[23-Jul-2018 14:04:26 Europe/Berlin] PHP Fatal error:  require(): Failed opening required '/GO6.3/vendor/composer/../sabre/uri/lib/functions.php' (include_path='.:/usr/local/lib/php') in /GO6.3/vendor/composer/autoload_real.php on line 66
[23-Jul-2018 14:04:29 Europe/Berlin] PHP Warning:  require(/GO6.3/vendor/composer/../sabre/uri/lib/functions.php): failed to open stream: No such file or directory in /GO6.3/vendor/composer/autoload_real.php on line 66
[23-Jul-2018 14:04:29 Europe/Berlin] PHP Fatal error:  require(): Failed opening required '/GO6.3/vendor/composer/../sabre/uri/lib/functions.php' (include_path='.:/usr/local/lib/php') in /GO6.3/vendor/composer/autoload_real.php on line 66
[23-Jul-2018 14:04:33 Europe/Berlin] PHP Warning:  require(/GO6.3/vendor/composer/../sabre/uri/lib/functions.php): failed to open stream: No such file or directory in /GO6.3/vendor/composer/autoload_real.php on line 66
[23-Jul-2018 14:04:33 Europe/Berlin] PHP Fatal error:  require(): Failed opening required '//GO6.3/vendor/composer/../sabre/uri/lib/functions.php' (include_path='.:/usr/local/lib/php') in /GO6.3/vendor/composer/autoload_real.php on line 66
[23-Jul-2018 14:06:33 Europe/Berlin] PHP Warning:  require(/GO6.3/vendor/composer/../sabre/xml/lib/Deserializer/functions.php): failed to open stream: No such file or directory in /GO6.3/vendor/composer/autoload_real.php on line 66
[23-Jul-2018 14:06:33 Europe/Berlin] PHP Fatal error:  require(): Failed opening required '/GO6.3/vendor/composer/../sabre/xml/lib/Deserializer/functions.php' (include_path='.:/usr/local/lib/php') in /GO6.3/vendor/composer/autoload_real.php on line 66
[23-Jul-2018 14:07:29 Europe/Berlin] PHP Warning:  require(/GO6.3/vendor/composer/../sabre/xml/lib/Deserializer/functions.php): failed to open stream: No such file or directory in /GO6.3/vendor/composer/autoload_real.php on line 66
[23-Jul-2018 14:07:29 Europe/Berlin] PHP Fatal error:  require(): Failed opening required '/GO6.3/vendor/composer/../sabre/xml/lib/Deserializer/functions.php' (include_path='.:/usr/local/lib/php') in /GO6.3/vendor/composer/autoload_real.php on line 66
[23-Jul-2018 12:08:34 UTC] ErrorException in /GO6.3/go/base/Session.php at line 77: session_start(): ps_files_cleanup_dir: opendir(/tmp) failed: Permission denied (13)
[23-Jul-2018 12:10:27 UTC] Exception in /GO6.3/go/core/fs/Folder.php at line 315: Could not create folder /var/lib/groupoffice/cache2
Permissions are all set to read/write - Do you have any clues what causes this?
mschering
Site Admin
Site Admin
Posts: 8235
Joined: Tue Apr 20, 2004 1:06 pm
Location: The Netherlands - Den Bosch
Contact:

Re: No modules available

Postby mschering » Tue Jul 24, 2018 7:48 am

Did you perhaps do a git checkout?

It seems the composer dependencies are not installed.

Please follow this procedure:

http://groupoffice.readthedocs.io/en/latest/index.html
Best regards,

Merijn Schering
Intermesh
mainroller
Posts: 4
Joined: Tue Jul 11, 2017 1:55 pm

Re: No modules available

Postby mainroller » Tue Jul 24, 2018 4:19 pm

Hi Merjin,

to be honest I am no professional in any case related to server configuration and am sure that I have no access on our shared hosting to do something like a git checkout. But I love Groupoffice since I installed it for my business in 2010 (we restore vespa oldtimers) because it is easy to use for my two computer-illiterate co-workers. I am very eager to use 6.3 and really hope to get it running somehow.

Of course I follow the instruction manual. I install via tarball download. PHP is 7.0

I flushed the cache and emptied the error log. Now the two errors are as follows:

Code: Select all

[24-Jul-2018 14:19:06 UTC] ErrorException in /webseiten/GO6.3/go/base/Session.php at line 77: session_start(): ps_files_cleanup_dir: opendir(/tmp) failed: Permission denied (13)
[24-Jul-2018 16:14:31 UTC] go\core\http\Exception in /webseiten/GO6.3/go/core/jmap/State.php at line 85: Unauthorized
ggomez
Posts: 3
Joined: Wed Feb 08, 2017 10:47 pm

Re: No modules available

Postby ggomez » Wed Jul 25, 2018 6:16 pm

Hello, the same thing happens to me, install version 6.3.23 and when I started with my user, I was pleased with the fact that there are no modules installed, the truth is that the product is very good and I would like to continue using it, can you help me? thank you very much!
ggomez
Posts: 3
Joined: Wed Feb 08, 2017 10:47 pm

Re: No modules available

Postby ggomez » Wed Jul 25, 2018 7:23 pm

Hello, the same thing happens to me, install version 6.3.23 and when I started with my user, I was pleased with the fact that there are no modules installed, the truth is that the product is very good and I would like to continue using it, can you help me? thank you very much!

error :

[proxy_fcgi:error] [pid 16040] [client 181.25.170.93:64354] AH01071: Got error 'PHP message: go\\core\\http\\Exception in /home/seguface/public_html/go/core/jmap/State.php at line 85: Unauthorized\n', referer: http://www.seguface.com/

Who is online

Users browsing this forum: No registered users and 5 guests

cron