Problems to install GO 6.3

Having trouble installing Group-Office? No worries. Help is on the way.

Moderator: Developers

lalves
Posts: 10
Joined: Tue Feb 23, 2016 9:06 pm

Problems to install GO 6.3

Postby lalves » Thu Sep 27, 2018 2:56 am

Hi everyone,

I am trying to install and test the new GO 6.3.
I installed fresh Debian 9 to install and test GO.

After I finished the installation, I opened the browser and navigated to the web address. All fine to this stage until on the middle of the process an error occurs and I can't proceed to finish the configuration.

The error the comes on my browser is this one:

Exception in /usr/share/groupoffice/go/core/data/Model.php at line 235: Can't set not existing property 'databaseVersion' in 'go\modules\core\users\model\Settings'

Debug dump:

Array
(
)


I looked at the log files and the error messages displayed are:

PHP Fatal error: Uncaught ErrorException: flock() expects parameter 1 to be resource, null given in /usr/share/groupoffice/go/core/util/Lock.php:76\nStack trace:\n#0 [internal function]: go\\core\\ErrorHandler::errorHandler(2, 'flock() expects...', '/usr/share/grou...', 76, Array)\n#1 /usr/share/groupoffice/go/core/util/Lock.php(76): flock(NULL, 3)\n#2 /usr/share/groupoffice/go/core/util/Lock.php(88): go\\core\\util\\Lock->unlock()\n#3 [internal function]: go\\core\\util\\Lock->__destruct()\n#4 {main}\n thrown in /usr/share/groupoffice/go/core/util/Lock.php on line 76

ErrorException in /usr/share/groupoffice/go/core/util/Lock.php at line 76: flock() expects parameter 1 to be resource, null given, referer: http://192.168.57.234/groupoffice/install/install.php

Has anyone encountered the same issues?

Thanks in advanced
peter_stirnberg
Posts: 279
Joined: Tue Dec 13, 2005 7:57 am

Re: Problems to install GO 6.3

Postby peter_stirnberg » Wed Oct 03, 2018 10:51 am

There is a bug in the install script. Check the ownership of /var/lib/groupoffice/cache and the files beneath. They should be www-data:www-data instead of root:root.
lalves
Posts: 10
Joined: Tue Feb 23, 2016 9:06 pm

Re: Problems to install GO 6.3

Postby lalves » Wed Oct 03, 2018 9:06 pm

peter_stirnberg wrote: Wed Oct 03, 2018 10:51 am There is a bug in the install script. Check the ownership of /var/lib/groupoffice/cache and the files beneath. They should be www-data:www-data instead of root:root.
Hi Peter,

Thanks for your reply.

I checked the permissions and ownership but they were owned already by www-data, and the problems persist.

Any other ideas to how can I fix it?
mschering
Site Admin
Site Admin
Posts: 8357
Joined: Tue Apr 20, 2004 1:06 pm
Location: The Netherlands - Den Bosch
Contact:

Re: Problems to install GO 6.3

Postby mschering » Thu Oct 04, 2018 7:36 am

The strange thing is that the clean install should create an empty folder /var/lib/groupoffice owned by www-data.
I'm going to test a clean install on debian today. I will make sure next version works.
Best regards,

Merijn Schering
Intermesh
peter_stirnberg
Posts: 279
Joined: Tue Dec 13, 2005 7:57 am

Re: Problems to install GO 6.3

Postby peter_stirnberg » Thu Oct 04, 2018 8:08 am

lalves wrote: Wed Oct 03, 2018 9:06 pm
peter_stirnberg wrote: Wed Oct 03, 2018 10:51 am There is a bug in the install script. Check the ownership of /var/lib/groupoffice/cache and the files beneath. They should be www-data:www-data instead of root:root.
Hi Peter,

Thanks for your reply.

I checked the permissions and ownership but they were owned already by www-data, and the problems persist.

Any other ideas to how can I fix it?
Strange, for me it worked but I did some more before:

I downloaded GO 6.3.38 and copied it over the docroot. Then I changed the ownership of the cache dir and then I did the install. After that I downloaded GO 6.3.39 and copied it over the docroot again - and it works.
mschering
Site Admin
Site Admin
Posts: 8357
Joined: Tue Apr 20, 2004 1:06 pm
Location: The Netherlands - Den Bosch
Contact:

Re: Problems to install GO 6.3

Postby mschering » Thu Oct 04, 2018 3:44 pm

I just checked with a fresh debian 9.5 install and an instal of 6.3.41 works without any issue.

Hopefully this issue is solved then!
Best regards,

Merijn Schering
Intermesh
lalves
Posts: 10
Joined: Tue Feb 23, 2016 9:06 pm

Re: Problems to install GO 6.3

Postby lalves » Thu Oct 04, 2018 7:42 pm

mschering wrote: Thu Oct 04, 2018 3:44 pm I just checked with a fresh debian 9.5 install and an instal of 6.3.41 works without any issue.

Hopefully this issue is solved then!
Hi Mischering,

Thnaks so much. It is working now.

I removed Groupoffice first and then use apt update and reinstalled GO.

Best regards
mschering
Site Admin
Site Admin
Posts: 8357
Joined: Tue Apr 20, 2004 1:06 pm
Location: The Netherlands - Den Bosch
Contact:

Re: Problems to install GO 6.3

Postby mschering » Thu Oct 04, 2018 7:53 pm

Good to hear!
Best regards,

Merijn Schering
Intermesh
eumx
Posts: 10
Joined: Wed Apr 04, 2012 12:28 pm

Re: Problems to install GO 6.3

Postby eumx » Fri Oct 12, 2018 8:47 am

It looks like issue is back with latest version groupoffice_6.3.42-php-70_all.deb (2018-10-09 15:04 27M)
I'm trying to install it on freshly installed Debian 9.5

[2018-10-12T08:46:40+00:00] Exception in /usr/share/groupoffice/go/core/db/Utils.php at line 21: SQLSTATE[42S02]: Base table or view not found: 1146 Table 'groupoffice.go_mail_counter' doesn't exist on query (109) ALTER TABLE `go_mail_counter`
ADD PRIMARY KEY (`host`),
ADD KEY `date` (`date`)



Debug dump:

Array
(
)

[Fri Oct 12 08:12:04.104965 2018] [:error] [pid 29134] [client 10.*.*.*:50268] Exception in /usr/share/groupoffice/go/core/db/Utils.php at line 21: SQLSTATE[42S02]: Base table or view not found: 1146 Table 'groupoffice.go_mail_count
er' doesn't exist on query (109) ALTER TABLE `go_mail_counter`\nADD PRIMARY KEY (`host`),\nADD KEY `date` (`date`), referer: http://10.*.*.*/groupoffice/install/install.php

[Fri Oct 12 08:12:36.013175 2018] [:error] [pid 29135] [client 10.*.*.*:50283] Exception in /usr/share/groupoffice/go/core/data/Model.php at line 235: Can't set not existing property 'databaseVersion' in 'go\\modules\\core\\users\\m
odel\\Settings', referer: http://10.*.*.*/groupoffice/install/upgrade.php

mschering wrote: Thu Oct 04, 2018 3:44 pm I just checked with a fresh debian 9.5 install and an instal of 6.3.41 works without any issue.

Hopefully this issue is solved then!
broberg
Posts: 10
Joined: Thu Jan 23, 2014 6:51 am

Re: Problems to install GO 6.3

Postby broberg » Fri Oct 12, 2018 11:37 am

I made some attempts today to install "groupoffice" on a fresh Debian 9.5 system. This ended up with the following messages:

[2018-10-12T11:29:55+00:00] Exception in /usr/share/groupoffice/go/core/data/Model.php at line 235: Can't set not existing property 'databaseVersion' in 'go\modules\core\users\model\Settings'



Debug dump:

Array
(
)
cvan-hoorn
Posts: 1
Joined: Mon Oct 15, 2018 7:14 am

Re: Problems to install GO 6.3

Postby cvan-hoorn » Mon Oct 15, 2018 7:24 am

Good morning,
i have this problem aswell. Did a fresh install on Debian Stretch with deb-Packages from your repository.

Installation runs without any problems. I opened the browser and typed the url to complete the installation. After i entered all information for an admin-account the web-installer ran into the same issues.

In /var/log/apache/error.log i can see the error-Messages

Code: Select all

[Mon Oct 15 08:47:26.448621 2018] [:error] [pid 16493] [client :49344] Exception in /usr/share/groupoffice/go/core/db/Utils.php at line 21: SQLSTATE[42S02]: Base table or view not found: 1146 Table 'groupoffice.go_mail_counter' doesn't exist on query (109) ALTER TABLE `go_mail_counter`\nADD PRIMARY KEY (`host`),\nADD KEY `date` (`date`), referer: https://<URL>/groupoffice/install/install.php
[Mon Oct 15 08:47:47.797495 2018] [:error] [pid 16458] [client :49368] Exception in /usr/share/groupoffice/go/core/data/Model.php at line 235: Can't set not existing property 'databaseVersion' in 'go\\modules\\core\\users\\model\\Settings', referer: https://194.94.24.100/groupoffice/install/upgrade.php
Also i checked the ownership of the directory /var/lib/groupoffice/ but it belongs to www-data.

Looking in the database the table which i named in the error doesn't exist. But i don't know if this table is nesessary if i don't use mailserver-Support by GO.

Best regards.
mschering
Site Admin
Site Admin
Posts: 8357
Joined: Tue Apr 20, 2004 1:06 pm
Location: The Netherlands - Den Bosch
Contact:

Re: Problems to install GO 6.3

Postby mschering » Tue Oct 16, 2018 10:17 am

Please try again with 6.3.43. This has been fixed.
Best regards,

Merijn Schering
Intermesh
broberg
Posts: 10
Joined: Thu Jan 23, 2014 6:51 am

Re: Problems to install GO 6.3

Postby broberg » Tue Oct 16, 2018 11:23 am

Installed the new version in a fresh Debian 9.5 installation and it worked fine.

Who is online

Users browsing this forum: No registered users and 2 guests