Uprading from 6.2 to 6.3

Having trouble installing Group-Office? No worries. Help is on the way.

Moderator: Developers

jakub
Posts: 4
Joined: Tue Mar 20, 2018 1:24 pm

Uprading from 6.2 to 6.3

Postby jakub » Fri Dec 13, 2019 8:39 am

Hi, I am upgrading from 6.2.122 php 7.1 to 6.3.84 php 7.1. Before installation I turn on “customfields” and “search” modules as it is in documentation.
Upgrade is not succesfull:

Upgrading Group-Office
Excuting query: ALTER TABLE `fs_search_queries` ENGINE=InnoDB;
SQLSTATE[42S02]: Base table or view not found: 1146 Table 'go2.fs_search_queries' doesn't exist
Query: ALTER TABLE `fs_search_queries` ENGINE=InnoDB;
Package: legacy
Module: files
Module installed version: 87
Module source version: 88

What can I do now?
jhsdurham
Posts: 75
Joined: Sun Sep 15, 2013 4:04 am

Re: Uprading from 6.2 to 6.3

Postby jhsdurham » Sat Dec 14, 2019 11:16 pm

I had this error along the way of trying to do the same upgrade path as you.

Under your admin login, disable the Files and File Search module. Then remove the module. Now try your upgrade and re-add the module if the upgrade completed.
jakub
Posts: 4
Joined: Tue Mar 20, 2018 1:24 pm

Re: Uprading from 6.2 to 6.3

Postby jakub » Wed Dec 18, 2019 1:47 pm

Hi @jhsdurham, I dont use Files and Files search modules so they are disabled always. :(

EDIT: now I see it on ftp that they are in modules, so I wil try remove.
beckhei
Posts: 1
Joined: Fri Feb 07, 2020 10:33 am

Re: Uprading from 6.2 to 6.3

Postby beckhei » Fri Feb 07, 2020 11:18 am

I am still running Group Office 6.2.125 on debian buster, but want to migrate to current 6.4 version.
According to documentation the installation has to be done by first migrating to 6.3, so I tried it by
- verifying that modules "customfields" and "search" are installed
- apt-get remove groupoffice-com
- mv /usr/share/groupoffice /root/groupofficebak
- change /etc/apt/sources.list entry to "deb http://repo.group-office.com/ 63-php-71 main"
- apt-get update
- apt-get install groupoffice
When stsrting the site on my server, I get an error:

Warning: could not run as root!

PDOException: SQLSTATE[42S02]: Base table or view not found: 1146 Table 'groupofficecom.core_user' doesn't exist in /usr/share/groupoffice/go/base/db/Columns.php:78
Stack trace:
...
Skipping module users because it's not available.
Excuting query: delete FROM `sync_user_note_book` WHERE userId not in (select id from core_user);
SQLSTATE[42S02]: Base table or view not found: 1146 Table 'groupofficecom.core_user' doesn't exist
Query: delete FROM `sync_user_note_book` WHERE userId not in (select id from core_user);
Package: legacy
Module: sync
Module installed version: 41
Module source version: 42

How can I get the core_user table? What is my mistake?
Thanks in advance for your time!
mschering
Site Admin
Site Admin
Posts: 8357
Joined: Tue Apr 20, 2004 1:06 pm
Location: The Netherlands - Den Bosch
Contact:

Re: Uprading from 6.2 to 6.3

Postby mschering » Tue Feb 11, 2020 3:10 pm

The procedure looks ok. But the core_user table should already be there when you get to this query.

Can you retry and check if there are errors prior to that? I think something else went wrong before.
Best regards,

Merijn Schering
Intermesh

Who is online

Users browsing this forum: No registered users and 3 guests

cron