Undefined index: columns with 6.3 & 6.4

Having trouble installing Group-Office? No worries. Help is on the way.

Moderator: Developers

Posts: 2
Joined: Tue Feb 11, 2020 4:49 pm

Undefined index: columns with 6.3 & 6.4

Postby ssa5 » Tue Feb 11, 2020 5:57 pm

A few days ago I downloaded v6.4.112 to try out in hopes of resolve an existing issue I had with v6.3. I backed up my database (mysqldump) and folder (tar). I installed 6.4 in a new virtualhost, and install advised using mysqlnd. I removed php72w-mysql-7.2.27-1.w7.x86_64 and installed php72w-mysqlnd-7.2.27-1.w7.x86_64. Problem was after install it kept looping back to the main install page. Removing the install directory then started giving me the following error:
Undefined index: columns

Then it got worse. I went back to my old & working v6.3 and got the same error "Undefined index: columns". I proceeded to uninstall mysqlnd and re-install php-mysql, restart apache, and still same error. One thing I did notice, in the sql backup file it has utf8 as character set. In trying out different fixes I noticed I could get the login screen at least AFTER I changed the character set from utf8 to latin1_general. The Mysql server default is utf8, and to be honest I never paid any attention to it before as it just worked. I have not made any changes to Mysql, so I am assuming it was utf8 before all this, and the original working group office db was in utf8 as well.

Edit: I am running Apache 2 & php 7.2.27 with Mariadb 10.0.38. I proceeded to install 2x versions of 6.3 and 2x of 6.4 each either php71 or 70 files. All 4 instances are not working, giving the undefined index mainly. I should add this server was running 6.3 for a long time until I went to install 6.4 recently.

Who is online

Users browsing this forum: No registered users and 4 guests