Undefined variable: return during installation

Having trouble installing Group-Office? No worries. Help is on the way.

Moderator: Developers

ignite
Posts: 1
Joined: Tue Feb 03, 2009 10:26 am

Undefined variable: return during installation

Postby ignite » Fri Dec 31, 2021 12:45 pm

Tried a fresh installation on a Almalinux, previously Centos, with DirectAdmin as control panel.
Downloaded v6.5.95 from https://github.com/Intermesh/groupoffice/releases
Uploaded everything in the public_html of the user (in DA this is /home/<username>/domains/<specific_domain>/public_html/)
Downloaded the gotest.php and the server passed (not everything green, but no showstoppers).

First step shows the install Group-Office screen, and the button to continue.
At the same time in the error logfile this appears;
[Fri Dec 31 13:31:00.519166 2021] [proxy_fcgi:error] [pid 1436858:tid 139718649906944] [client 80.201.152.232:63729] AH01071: Got error 'PHP message: PDOException in /home/<username>/domains/<specific_domain>/public_html/go/core/db/Connection.php at line 132: SQLSTATE[HY000] [1045] Access denied for user 'groupoffice'@'localhost' (using password: NO)'
This seems weird, because I did not get to a point where I had to enter any credentials for the db.

The next screen shows the page in text-html and stops with an error;
ErrorException in /home/<username>/domains/<specific_domain>/public_html/install/gotest.php at line 911: Undefined variable: return at 2021-12-31T12:37:20+00:00
In the error logfile this appears;
[Fri Dec 31 13:37:20.278667 2021] [proxy_fcgi:error] [pid 1436858:tid 139718381340416] [client 80.201.152.232:63941] AH01071: Got error 'PHP message: ErrorException in /home/<username>/domains/<specific_domain>/public_html/install/gotest.php at line 911: Undefined variable: return', referer: https://<specific_domain>/install/

I saw in the error logfile when accessing the gotest.php the following;
[Fri Dec 31 13:25:44.925246 2021] [proxy_fcgi:error] [pid 1436858:tid 139718364555008] [client 80.201.152.232:63537] AH01071: Got error 'PHP message: PHP Notice: A non well formed numeric value encountered in /home/<username>/domains/<specific_domain>/public_html/gotest.php on line 68PHP message: PHP Notice: A non well formed numeric value encountered in /home/<username>/domains/<specific_domain>/public_html/gotest.php on line 953'

I expect it is something silly on my end, but it is from version 3.7 that I installed a Group-Office and I'm not sure where to look.
Any help would be appreciated.

Who is online

Users browsing this forum: Bing [Bot] and 7 guests

cron