Problems updating 6.2.125 to 6.2.134 and further

Having trouble installing Group-Office? No worries. Help is on the way.

Moderator: Developers

wwwchr1sde
Posts: 7
Joined: Fri Feb 01, 2019 11:32 am

Problems updating 6.2.125 to 6.2.134 and further

Postby wwwchr1sde » Wed Jan 19, 2022 2:41 pm

I'm using Group-Office for quite some years now and I am actually stuck using version 6.2.125

I tried updating to newer versions some times but encountered problems that I couldn't solve. Now I found out by chance that I could switch the PHP version up to the latest in my hosting settings and a fresh test install worked - when I tried loggin in to my 6.2. it didn't work - so I switched back the PHP version and 6.2.125 worked again.

Now I'm willing to update to the latest version but I'm running into problems even for the little step from 6.2.125 to 6.2.134.

After updating I get the following message when trying to access a calendar or opening a view of multiple calendars:

SQLSTATE[42S02]: Base table or view not found: 1146 Table 'DBXXX.em_aliases' doesn't exist

I installed a fresh copy of 6.2.125 to compare it with my existing setup. I found this comparing the databases:
old

CREATE TABLE `ab_addresslists` (
`id` int(11) NOT NULL AUTO_INCREMENT,
`addresslist_group_id` int(11) DEFAULT NULL,
`user_id` int(11) NOT NULL DEFAULT '0',
`acl_id` int(11) NOT NULL DEFAULT '0',
`name` varchar(255) COLLATE utf8mb4_unicode_ci DEFAULT NULL,
`default_salutation` varchar(50) COLLATE utf8mb4_unicode_ci DEFAULT NULL,
`ctime` int(11) NOT NULL DEFAULT '0',
`mtime` int(11) NOT NULL DEFAULT '0',
PRIMARY KEY (`id`)
) ENGINE=InnoDB DEFAULT CHARSET=utf8mb4 COLLATE=utf8mb4_unicode_ci ROW_FORMAT=DYNAMIC;
fresh install:

CREATE TABLE `ab_addresslists` (
`id` int(11) NOT NULL AUTO_INCREMENT,
`addresslist_group_id` int(11) DEFAULT NULL,
`user_id` int(11) NOT NULL DEFAULT '0',
`acl_id` int(11) NOT NULL DEFAULT '0',
`name` varchar(255) DEFAULT NULL,
`default_salutation` varchar(50) DEFAULT NULL,
`ctime` int(11) NOT NULL DEFAULT '0',
`mtime` int(11) NOT NULL DEFAULT '0',
PRIMARY KEY (`id`)
) ENGINE=InnoDB DEFAULT CHARSET=utf8mb4;
This occurs in a lot of tables.

Further down I found that some tables were missing in the one or other database:

only available in old database:
ab_sendmailing_companies
ab_sendmailing_contacts
bl_ips
cf_8
cms_categories
cms_files
cms_files_categories
cms_folders
cms_sites
cms_user_folder_access
cms_user_site_filter
dav_locks
fs_files_old
fs_folders_old
ml_mailings
ml_mailing_users
ml_sendmailing_users

only available in new database:
emp_folders
em_accounts
em_accounts_collapsed
em_accounts_sort
em_aliases
em_contacts_last_mail_times
em_filters
em_folders
em_folders_expanded
em_labels
em_links
em_messages_cache
co_categories
co_comments
go_links_em_links
su_visible_lists

Before updating to 6.2.134 I made sure that modules "search" and "extra fields" were activated. After the update I got the message:
Updating Group-Office database
Database updated to version 20211209
Removing cached javascripts...
Can I simply add the missing Database tables ore is that not enough to fix my problems.

Thanks for your support.

Who is online

Users browsing this forum: No registered users and 14 guests

cron