Access denied to view the folder..

Having trouble installing Group-Office? No worries. Help is on the way.

Moderator: Developers

senthilapt
Posts: 2
Joined: Wed Mar 22, 2006 7:03 am
Location: India
Contact:

Access denied to view the folder..

Postby senthilapt » Wed Mar 22, 2006 9:00 am

Hi,

I just installed GO 2.15 on Fedora 4. It is working fine except i cant view the folders which i created inside GO. I changed the permission of /home/groupoffice to 777. GO creates the folder with the following permission: d--xrw---x. If I change this manually then it is working fine. Otherwise I cant view the folder inside the GO. My PHP version is 5.1.2. Can anybody guide me to solve this?

Regards
Senthil
rpcs
Posts: 6
Joined: Mon May 15, 2006 7:38 pm

Postby rpcs » Fri May 19, 2006 3:33 pm

I'm also having a similar problem. After installing GO, I install the Files module but then when I click on Files I get an error message saying that it failed creating the directory .../data/users/admin. The folder is writeable and I also changed the value of the $create_mode variable to '0777' in Group-Office.php. Same thing happens when I add other users. I can add them fine, but then when logged in as that user and clicking on Files I get the same error message. GO is not creating the folders as writeable, and if I go in and manually change them then I can view the folder.
User avatar
dkittell
Site Admin
Site Admin
Posts: 808
Joined: Tue May 25, 2004 10:32 pm
Location: Michigan, USA
Contact:

Postby dkittell » Sat May 20, 2006 3:35 am

Take a look at the PHP chmod code. At one time it was part of the installation of GO to change the permissions of a file/folder to allow someone to immediately start working. I havn't visited the code in a while but should be a decently easy fix
David Kittell
Owner / Developer
Kittell.net
me-one
Posts: 2
Joined: Tue May 09, 2006 7:58 am

(strange) solution

Postby me-one » Thu Sep 07, 2006 8:46 pm

I've had the same (?) problem:

everytime a new folder/file was created the permissions were set to "--xrw---x" making it unable to open. I've set the create_mode to '0755' wich should have fixed the problem (as i understand some successfully people in the forum) but 0755 brought me this: "-wxrw--wt"

i am using the Pro version so i cannot 'just' take a look at the code ...

Experimenting with some values for 'create_mode' i figured out that '8' brought me "-----x---" and it looks like i have to count decimal bits:
--------x is 1
-------w- is 2
------r-- is 4
-----x--- is 8
-----x--x is 9
a.s.o.

so i guessed that 502 should be rwxrw-rw- (or 0755) and i was right. So now my config says 504 to represent 0770 wich is what i want right now. File permissions seem not to be changed by this .. uploaded files seem to always get 666 or rw-rw-rw- mode

hope my posting helps someone :wink:

me-one
webwolfi
Posts: 616
Joined: Sat May 27, 2006 7:54 am
Location: Vienna/Austria

Postby webwolfi » Fri Sep 08, 2006 11:02 am

just key "chmod" into google!

there you will find the answer
User avatar
ttimalsina
Posts: 56
Joined: Thu Apr 22, 2004 5:23 pm
Location: San Francisco, California, USA

Postby ttimalsina » Sun Dec 03, 2006 10:17 pm

I had the same problem. Once you install GO change $config['create_mode'] to writeable based on your server setup on config.php

In my case changing to $config['create_mode']='0755'; from $config['create_mode']='755'; worked.

8)

Who is online

Users browsing this forum: No registered users and 2 guests

cron