WAMP INSTALLATION

Having trouble installing Group-Office? No worries. Help is on the way.

Moderator: Developers

funkyfela
Posts: 2
Joined: Sat May 09, 2009 2:30 pm

WAMP INSTALLATION

Postby funkyfela » Sat May 09, 2009 3:09 pm

HElo
I was asked to design an intranet and so i asked and was told group-office is good.
am using wamp on my laptop to configure it, i have few issues on red(i know its a hitch my computer does not meet a recomendation)
my proble is how to fix the problems.
These are the problem:

IMAP support : Warning: IMAP extension not installed, E-mail module will not work.
libwbxml : Warning: libwbxml2 is not installed. Synchronization will not work!
TAR Compression : Warning: tar is not installed or not executable.
ZIP Compression : Warning: zip is not installed or not executable.
TNEF : Warning: tnef is not installed or not executable. you can't view winmail.dat attachments in the email module.
Ioncube : Warning: Ioncube is not installed. The professional version will not run.


i need help on these issues.

thanks
funkyfela
Posts: 2
Joined: Sat May 09, 2009 2:30 pm

Re: WAMP INSTALLATION

Postby funkyfela » Sat May 09, 2009 5:01 pm

so far i have been able to solve the issue with imap,
i googled and found a solution.

incase it helps,
all that need be done is enable imap on wamp.
remove the semicolon in front of ;extension=php_imap.dll in php.ini then restart the service.

on ioncube
google for iocube, when u locate the file (comes in 3 flavors, zip, tar, installer)
place the fold i.e ioncube in wamp (am using wamp)
open php.ini, locate
;Enable compatibility mode with Zend Engine 1 (PHP 4.x)
under place
zend_extension_ts = "C:\wamp\ioncube\ioncube_loader_win_5.2.dll"
your final result should be (feel free to copy and paste)

; Enable compatibility mode with Zend Engine 1 (PHP 4.x)
zend.ze1_compatibility_mode = Off
zend_extension_ts = "C:\wamp\ioncube\ioncube_loader_win_5.2.dll"

but still need help on TNEF, libwbxml, ZIP COMPRESSION, TAR COMPRESSION
i have winzip and winrar installed on my machine still cant understand why zip and rar be an issue.

hope to get help

thanx
mschering
Site Admin
Site Admin
Posts: 8154
Joined: Tue Apr 20, 2004 1:06 pm
Location: The Netherlands - Den Bosch
Contact:

Re: WAMP INSTALLATION

Postby mschering » Mon May 11, 2009 7:22 pm

They currently don't work on Windows. I don't know if winzip can be used from a command line. Maybe you can help?
Best regards,

Merijn Schering
Intermesh
insultant
Posts: 1
Joined: Sat Oct 10, 2009 6:37 am

Re: WAMP INSTALLATION

Postby insultant » Sat Oct 10, 2009 6:41 am

I realize this is a bit late in answering the winzip command line question :-0 but I thought I would post it for others who fall upon this page.

The answer is yes. It takes an addon and you can get it here: http://www.winzip.com/prodpagecl.htm

It works great and you can extract tarballs, gz, etc.
mschering
Site Admin
Site Admin
Posts: 8154
Joined: Tue Apr 20, 2004 1:06 pm
Location: The Netherlands - Den Bosch
Contact:

Re: WAMP INSTALLATION

Postby mschering » Sun Oct 11, 2009 6:35 am

Group-Office already supports this out of the box now.

All the binaries for zip and wbxml are in the folder controls/win32. The installation should automatically configure them but I've heard before of a case where it didn't work. You can configure them manually in config.php then. The values are cmd_zip, cmd_unzip, cmd_wbxml2xml etc.
Best regards,



Merijn Schering

Intermesh
grooff
Posts: 14
Joined: Sat May 07, 2016 2:54 pm

Re: WAMP INSTALLATION

Postby grooff » Sat May 07, 2016 3:59 pm

Hi. It seem that groupoffice-com-6.2.3.tar.gz did not include these few binaries based what the files I download at SourceForge.
Anyway I manage to fix the "tar.exe" error, whether or not it actually work I do not know. But here how I did it.

Download http://gnuwin32.sourceforge.net/packages/gtar.htm
In the .zip files there is an tar.exe
I copy that into \controls\win32
And open Group Office's config.php and added this
$config["cmd_tar"]='D:/Software/Ampps/www/groupoffice/controls/win32/tar.exe';

Refresh my groupoffice/install and Tar error is gone and I get "OK"

Return to “Installation”

Who is online

Users browsing this forum: No registered users and 1 guest

cron