[permission denied] resource after "now"

Get help from the community here.

Moderator: Developers

michaeled
Posts: 86
Joined: Wed May 09, 2012 2:00 pm

[permission denied] resource after "now"

Postby michaeled » Mon Feb 02, 2015 3:25 pm

Hi,

It's a strange bug we have since our upgrade to version 6 Pro.

For some users, when they add an event with a resource an error message appears "permission denied". But after have closed the event windows and have refreshed, the event with the resource is here.
This bug is reproductible all time after today, but when the user add an event with this same resource to an older day (before today) the bug is not present and all work perfectly ...

I'am not able to determine why some resource are impacted and others not...

Can you help me please ?

Thank you.

Michael.
michaeled
Posts: 86
Joined: Wed May 09, 2012 2:00 pm

Re: [permission denied] resource after "now"

Postby michaeled » Fri Feb 06, 2015 11:49 am

Hi,

Any idea ?

Regards,

Michael.
mschering
Site Admin
Site Admin
Posts: 8292
Joined: Tue Apr 20, 2004 1:06 pm
Location: The Netherlands - Den Bosch
Contact:

Re: [permission denied] resource after "now"

Postby mschering » Fri Feb 20, 2015 8:58 am

Please try this with the latest version. I believe this has been fixed.
Best regards,

Merijn Schering
Intermesh
michaeled
Posts: 86
Joined: Wed May 09, 2012 2:00 pm

Re: [permission denied] resource after "now"

Postby michaeled » Fri Mar 06, 2015 2:49 pm

Hi Merijn,

I've just tried with the 6.1.25 version, the problem is still present :-(

Michael.
mschering
Site Admin
Site Admin
Posts: 8292
Joined: Tue Apr 20, 2004 1:06 pm
Location: The Netherlands - Den Bosch
Contact:

Re: [permission denied] resource after "now"

Postby mschering » Wed Mar 11, 2015 9:54 am

Can you press CTRL + F7 and then reproduce the error. I would like to see the debug output on that.
Best regards,

Merijn Schering
Intermesh
michaeled
Posts: 86
Joined: Wed May 09, 2012 2:00 pm

Re: [permission denied] resource after "now"

Postby michaeled » Thu Mar 12, 2015 1:53 pm

I've tried with the debug windows,

so, now the error is this one :

Code: Select all

Accès refusé GO\Base\Model\User pk: 471
There is nothing in the error tab , but there is this in the log tab :

Code: Select all


[2015-03-12 14:40] INIT
Controller route r=core/multiRequest
Controller route r=calendar/group/store
Controller route r=calendar/group/groupsWithResources
Script running at [shutdown] for 1426167602.7957ms


[2015-03-12 14:40] INIT
Controller route r=calendar/event/load
Script running at [shutdown] for 1426167603.5129ms


[2015-03-12 14:40] INIT
Controller route r=calendar/event/submit
EXCEPTION: exception 'GO\Base\Exception\AccessDenied' with message 'Accès refusé

GO\Base\Model\User pk: 471' in /home/michael/source/groupoffice/6.1.25/groupoffice-com-6.1.25/go/base/db/ActiveRecord.php:1974
Stack trace:
#0 /home/michael/source/groupoffice/6.1.25/groupoffice-com-6.1.25/go/base/db/ActiveRecord.php(4820): GO\Base\Db\ActiveRecord->findByPk(471, true)
#1 /home/michael/source/groupoffice/6.1.25/groupoffice-com-6.1.25/modules/calendar/model/Event.php(756): GO\Base\Db\ActiveRecord->addReminder('test', 1426234200, 471, 1426234500)
#2 /home/michael/source/groupoffice/6.1.25/groupoffice-com-6.1.25/modules/calendar/model/Event.php(711): GO\Calendar\Model\Event->setReminder()
#3 /home/michael/source/groupoffice/6.1.25/groupoffice-com-6.1.25/go/base/db/ActiveRecord.php(3207): GO\Calendar\Model\Event->afterSave(true)
#4 /home/michael/source/groupoffice/6.1.25/groupoffice-com-6.1.25/modules/calendar/controller/EventController.php(324): GO\Base\Db\ActiveRecord->save(true)
#5 /home/michael/source/groupoffice/6.1.25/groupoffice-com-6.1.25/modules/calendar/controller/EventController.php(216): GO\Calendar\Controller\EventController->_saveResources(Array, Object(GO\Calendar\Model\Event), true, Array)
#6 /home/michael/source/groupoffice/6.1.25/groupoffice-com-6.1.25/go/base/controller/AbstractModelController.php(117): GO\Calendar\Controller\EventController->afterSubmit(Array, Object(GO\Calendar\Model\Event), Array, Array)
#7 /home/michael/source/groupoffice/6.1.25/groupoffice-com-6.1.25/go/base/controller/AbstractController.php(519): GO\Base\Controller\AbstractModelController->actionSubmit(Array)
#8 /home/michael/source/groupoffice/6.1.25/groupoffice-com-6.1.25/go/base/controller/AbstractController.php(427): GO\Base\Controller\AbstractController->callActionMethod('actionsubmit', Array)
#9 /home/michael/source/groupoffice/6.1.25/groupoffice-com-6.1.25/go/base/Router.php(159): GO\Base\Controller\AbstractController->run('submit', Array)
#10 /home/michael/source/groupoffice/6.1.25/groupoffice-com-6.1.25/index.php(79): GO\Base\Router->runController()
#11 {main}
Script running at [shutdown] for 1426167620.232ms


[2015-03-12 14:41] INIT
Controller route r=core/multiRequest
Controller route r=reminder/store
Controller route r=email/account/checkUnseen
Session writing closed
GO\Email\Model\ImapMailbox:array (
'name' => 'INBOX',
)
imap::connect(ns0xxxxx, 143, nathalie.pledel@xxxxx, ***, 0, )
Authententication failed for user nathalie.pledel@xxxxx on IMAP server ns0xxxxx

A1 NO [ AUTHENTICATIONFAILED ] Authentication failed.
Total unseen: 0
Script running at [shutdown] for 1426167693.28ms


[2015-03-12 14:42] INIT
Controller route r=summary/announcement/store
Script running at [shutdown] for 1426167746.775ms


[2015-03-12 14:43] INIT
Controller route r=core/multiRequest
Controller route r=reminder/store
Controller route r=email/account/checkUnseen
Session writing closed
GO\Email\Model\ImapMailbox:array (
'name' => 'INBOX',
)
imap::connect(ns0xxxxx, 143, nathalie.pledel@xxxxx, ***, 0, )
Authententication failed for user nathalie.pledel@xxxxx on IMAP server ns0.xxxxx

A1 NO [ AUTHENTICATIONFAILED ] Authentication failed.
Total unseen: 0
Script running at [shutdown] for 1426167814.1639ms
mschering
Site Admin
Site Admin
Posts: 8292
Joined: Tue Apr 20, 2004 1:06 pm
Location: The Netherlands - Den Bosch
Contact:

Re: [permission denied] resource after "now"

Postby mschering » Mon Mar 23, 2015 7:31 am

Please try the latest version. I think I fixed this.
Best regards,

Merijn Schering
Intermesh
michaeled
Posts: 86
Joined: Wed May 09, 2012 2:00 pm

Re: [permission denied] resource after "now"

Postby michaeled » Fri Mar 27, 2015 2:20 pm

Hi Merijn,

I've just tried the 6.1.27 version, same result : "accès refusé"

:-(

Michael.
mschering
Site Admin
Site Admin
Posts: 8292
Joined: Tue Apr 20, 2004 1:06 pm
Location: The Netherlands - Den Bosch
Contact:

Re: [permission denied] resource after "now"

Postby mschering » Wed Apr 08, 2015 6:57 am

Will be fixed in the next update!
Best regards,

Merijn Schering
Intermesh

Who is online

Users browsing this forum: No registered users and 4 guests

cron