go_cron doesn't exist, but can't create it either

Get help from the community here.

Moderator: Developers

Posts: 66
Joined: Sun Sep 15, 2013 4:04 am

go_cron doesn't exist, but can't create it either

Postby jhsdurham » Wed Mar 25, 2015 4:16 pm

Windows Server admins... in case you encounter this.

Apache 2.4, MySQL 5.6, PHP 5.4, Windows 2008r2 and had GO v5.0.89 running fluidly.

Upon upgrade to GO 6.1.25, things -seemed- fine, no errors appeared during the upgrade screens. But a week a later when I needed to use the Remove Duplicates admin tool, or any admin tool, they wouldn't work. Suddenly I kept getting a "go_cron" doesn't exist error, and a "go_saved"exports" error as well.

I tried copying the 5.0.89 go_cron over from a backup, but it didn't work because the structure from 89 to the new 6 series is different.

When I tried to use MySQL workbench or command line to delete the table and re-create it with the correct new structure, MySQL responded that the table did not exist.. which was crazy, because I could see it in the list of tables in Workbench. It was very frustrating.. couldn't recreate it, couldn't delete it. The fix was this:

Stop your web server service
Stop the MySQL service
Rename the ib_logfile0 and iblogfile1 files in your root mysql data folder to any other name
Copy the table go_cron from a backup into the data folder that has all your other group office tables (.frm and .ibd files)
Restart the MySQL service
Immediately get into mysql command line and run the Drop table and Discard Tablespace commands on the table name
Now run the create table commands

This process forces MySQL to regenerate the ib_logfile files, and working quickly, you should be able to avoid the "table doesn't exist" error when trying to drop the table, and then can re-create it successfully.

As I type this.. I suppose it may also have been possible to even try using the ALTER command to update the structure of the table so that you wouldn't be losing all the data in that table. But as we never use cron, it doesn't worry me.

But I did have this same problem with 2 other tables after the upgrade: go_saved_exports and ld_leave_days which were also fixed using the same approach. I also was not concerned about losing the contents of those. Hope this helps someone else.

Who is online

Users browsing this forum: No registered users and 16 guests