[Solved] File size limited to 9MB for emails and files

Get help from the community here.

Moderator: Developers

Hoschi
Posts: 3
Joined: Sun Feb 19, 2017 5:05 pm

[Solved] File size limited to 9MB for emails and files

Postby Hoschi » Fri Mar 03, 2017 5:50 pm

OS: Debian 3.2.78-1 x86_64
GO version: 6.2.25
PHP version: 7.0.16
Webserver: Apache w. FastCGI

Hi @all,
actually I'm unable to add attachments of more then 9MB size to new emails. Also, it's not possible to upload such files to a folder. I made some tests and was able to reproduce the behavior at will:
8,97MB: works
9,09MB: fails
Where is this value of 9MB set?

What I've checked so far:
(1) PHP settings:
post_max_size 15M
upload_max_filesize 15M

(2) GO config.php:
$config["upload_max_filesize"]='20000000';
$config["max_attachment_size"]='20000000';

After changing the max_attachment_size parameter I could see in the email attachment upload dialog the windows title change from "max upload 20Mb" to "max upload 19mb", so it is proven the (changed) parameter is fetched by GO.

(3) Tried other PHP webmailers:
Rainloop: works
Webmail Lite: works

(4) Switched on debug mode:
[jon.doe@my.tld] Connect: mysql:host=xx.xx.xxx.xxx;dbname=lnsfwdch_goff792, lnsfwdch_goff792, ***
[jon.doe@my.tld] [2017-03-03 18:57] INIT POST /office/index.php?r=core/plupload&security_token=rOISEe1ykQZ78DRFWNm9
[jon.doe@my.tld] Controller route r=core/plupload
[jon.doe@my.tld] EXCEPTION: Exception: File too large in /var/www/vhosts/my.tld/httpdocs/office/go/base/component/Plupload.php:57
[jon.doe@my.tld] Stack trace:
[jon.doe@my.tld] #0 /var/www/vhosts/my.tld/httpdocs/office/controller/CoreController.php(641): GO\Base\Component\Plupload::handleUpload()
[jon.doe@my.tld] #1 /var/www/vhosts/my.tld/httpdocs/office/go/base/controller/AbstractController.php(518): GO\Core\Controller\CoreController->actionPlupload(Array)
[jon.doe@my.tld] #2 /var/www/vhosts/my.tld/httpdocs/office/go/base/controller/AbstractController.php(431): GO\Base\Controller\AbstractController->callActionMethod('actionplupload', Array)
[jon.doe@my.tld] #3 /var/www/vhosts/my.tld/httpdocs/office/go/base/Router.php(182): GO\Base\Controller\AbstractController->run('plupload', Array)
[jon.doe@my.tld] #4 /var/www/vhosts/my.tld/httpdocs/office/index.php(82): GO\Base\Router->runController()
[jon.doe@my.tld] #5 {main}


Any ideas, anyone?

Edit 2017-03-04:
Ok, my fault, got it working now. The solution is to change the value of parameter
$config["max_file_size"]='10000000';
I mixed it up with the php parameter "upload_max_filesize" :-(
andrejones
Posts: 2
Joined: Wed Jan 04, 2017 7:34 pm
Location: Brazil
Contact:

Re: [Solved] File size limited to 9MB for emails and files

Postby andrejones » Thu Mar 09, 2017 5:37 pm

Thanks for your help! I worked for me as well! :D

Return to “General help”

Who is online

Users browsing this forum: Bing [Bot] and 5 guests

cron