SOLVED - Upgrading to 6.2 (MUST use 7.1 not 7.2)

Get help from the community here.

Moderator: Developers

jhsdurham
Posts: 67
Joined: Sun Sep 15, 2013 4:04 am

SOLVED - Upgrading to 6.2 (MUST use 7.1 not 7.2)

Postby jhsdurham » Fri Jul 27, 2018 7:02 am

For Windows server admins or otherwise (I assume.. based on my Windows experience tonight)

You MUST use only PHP 7.1, and ioncube loaders for 7.1 in order to upgrade to GO 6.2. I spent 4 hours of hell trying to update to 6.2 until I went backwards in PHP version like this. It does not say this anywhere on this site or in the upgrading documents online at https://www.group-office.com/wiki/Upgrading#Manual_upgrade

I was upgraded to 7.2 and getting errors of this in my php error log:
Declaration of goMail::SendMail($sm) must be compatible with GoBaseBackendDiff::SendMail($rfc822, $forward = , $reply = , $parent = )

Secondly, for Windows Servers, when using Z-Push, you still must comment out lines in this file around line 888 to skip past POSIX commands or you will get a non-stop rant about json errors and never see anything in your ActiveSync Management panel

\modules\z-push\lib\utils\utils.php

Comment out the code AFTER this line and until just before the first "return true;" line
public static function FixFileOwner($file) {
peter_stirnberg
Posts: 275
Joined: Tue Dec 13, 2005 7:57 am

Re: SOLVED - Upgrading to 6.2 (MUST use 7.1 not 7.2)

Postby peter_stirnberg » Fri Jul 27, 2018 8:12 am

There are only GO 6.2 releases depending on php 7.0 and 7.1 for download in sourceforge available.

Who is online

Users browsing this forum: No registered users and 4 guests