Page 1 of 1

Error trying to upload documents using jupload2

Posted: Tue Jun 16, 2009 6:31 am
by brin
Im trying to upload a document using jupload2 and getting the following error.
11:08:07.101 [ERROR] [wjhk.jupload2.exception.JUploadExceptionUploadFailed] wjhk.jupload2.policies.DefaultUploadPolicy.checkUploadSuccess(): The string "SUCCESS" was not found in the response body (wjhk.jupload2.policies.DefaultUploadPolicy.checkUploadSuccess(): The string "SUCCESS" was not found in the response body)
11:08:07.132 wjhk.jupload2.exception.JUploadExceptionUploadFailed: wjhk.jupload2.policies.DefaultUploadPolicy.checkUploadSuccess(): The string "SUCCESS" was not found in the response body

11:08:07.132 at wjhk.jupload2.policies.DefaultUploadPolicy.checkUploadSuccess(DefaultUploadPolicy.java:650)

11:08:07.132 at wjhk.jupload2.upload.DefaultFileUploadThread.doUpload(DefaultFileUploadThread.java:735)

11:08:07.132 at wjhk.jupload2.upload.DefaultFileUploadThread.run(DefaultFileUploadThread.java:501)

Can someone please let me know if i need to check some settings to get it working.

Re: Error trying to upload documents using jupload2

Posted: Thu Jun 18, 2009 7:03 am
by mschering
Do you have errors in the apache log?

Re: Error trying to upload documents using jupload2

Posted: Wed Aug 19, 2009 7:43 am
by rawk_xian
OK, to solve this problem, just edit one line.

modules/files/jupload/upload.php The last line of this file.

echo 'SUCCESS';
--> echo "SUCCESS\n";


-:)

Re: Error trying to upload documents using jupload2

Posted: Thu Aug 20, 2009 9:12 am
by mschering
Hmm that's strange. Don't know why that's required but I've changed it in the main source.

Thanks!

Re: Error trying to upload documents using jupload2

Posted: Thu Oct 22, 2009 10:52 am
by nessy
Hi!

I have the same problem: The string "^SUCCESS$" was not found in the response body.

the last line in ../modules/files/jupload/upload.php is (RELEASE 2009/08/18 3.2.25)
echo "SUCCESS\n";

no error in apache error.log


12:41:59.693 [INFO] Debug level set to 0
12:41:59.760 [INFO] Current debug output file: C:\DOKUME~1\nesvadba\LOKALE~1\Temp\jupload_425167989145829341_log.txt
12:41:59.960 [INFO] JUpload applet, version 3.5.1 [SVN-Rev: 537] (compiled: 10/17/2008 10:26 PM), available at http://jupload.sourceforge.net/
12:41:59.960 [INFO] maxFileSize: 25600000
12:42:19.012 [INFO] Debug level set to 1
12:42:19.012 [INFO] Current debug output file: C:\DOKUME~1\nesvadba\LOKALE~1\Temp\jupload_425167989145829341_log.txt
12:42:19.012 [INFO] JUpload applet, version 3.5.1 [SVN-Rev: 537] (compiled: 10/17/2008 10:26 PM), available at http://jupload.sourceforge.net/
12:42:19.012 [DEBUG] debugLevel: 1 (debugfile: C:\DOKUME~1\nesvadba\LOKALE~1\Temp\jupload_425167989145829341_log.txt)
12:42:19.012 [INFO] maxFileSize: 25600000
12:42:19.012 [ERROR] [wjhk.jupload2.exception.JUploadExceptionUploadFailed] wjhk.jupload2.policies.DefaultUploadPolicy.checkUploadSuccess(): The string "^SUCCESS$" was not found in the response body (wjhk.jupload2.policies.DefaultUploadPolicy.checkUploadSuccess(): The string "^SUCCESS$" was not found in the response body)
12:42:19.012 wjhk.jupload2.exception.JUploadExceptionUploadFailed: wjhk.jupload2.policies.DefaultUploadPolicy.checkUploadSuccess(): The string "^SUCCESS$" was not found in the response body
12:42:19.012 at wjhk.jupload2.policies.DefaultUploadPolicy.checkUploadSuccess(DefaultUploadPolicy.java:694)
12:42:19.012 at wjhk.jupload2.upload.DefaultFileUploadThread.doUpload(DefaultFileUploadThread.java:762)
12:42:19.012 at wjhk.jupload2.upload.DefaultFileUploadThread.run(DefaultFileUploadThread.java:528)


Thanxs
Gerhard

Re: Error trying to upload documents using jupload2

Posted: Thu Oct 22, 2009 10:57 am
by mschering
Check the contents of the debug log file:

C:\DOKUME~1\nesvadba\LOKALE~1\Temp\jupload_425167989145829341_log.txt

Re: Error trying to upload documents using jupload2

Posted: Thu Oct 22, 2009 11:45 am
by nessy
Thanks for the prompt reply.

the content is:
12:42:31.274 [DEBUG] Interrupted: [null]

thats all.

the upload from small files works fine.

Gerhard

Re: Error trying to upload documents using jupload2

Posted: Thu Oct 22, 2009 12:50 pm
by mschering
Do you see it connecting to the server? Is there an entry in the access log?

Re: Error trying to upload documents using jupload2

Posted: Thu Oct 22, 2009 1:44 pm
by nessy
yes.

click "Upload":
81.223.151.146 - - [22/Oct/2009:15:15:12 +0200] "POST /gletscher/modules/files/jupload/upload.php?id=33 HTTP/1.1" 200 12 "-" "Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; GTB6; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.04506.30; .NET CLR 3.0.04506.648; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729)"


New Info:
now i test the upload with Firefox 3.5.3 - the upload works.
with IE 8.0 it dosen't works.

The problem is not the server, it is the client.

Is the problem already known?

Gerhard

Re: Error trying to upload documents using jupload2

Posted: Fri Oct 23, 2009 7:22 am
by mschering
No it should work fine. There must be some kind of error on the server side but somehow it's not logged on your system.