JsonStore load exception error in Modules

Having trouble installing Group-Office? No worries. Help is on the way.

Moderator: Developers

tushar
Posts: 2
Joined: Sat Dec 13, 2014 7:38 pm

JsonStore load exception error in Modules

Postby tushar » Sat Dec 13, 2014 7:51 pm

I get this error when I click on Modules:

An error occurred on the webserver. Contact your system administrator and supply the detailed error.

JsonStore load exception occurred

My goffice is hosted on Arvixe web hosting. I installed the community version using Softaculous. I then bought the pro license and put the text file in my /goffice directory. I also updated ioncube. When I login to group-office I do not get the synchronization tab in settings. If I click on modules I get the above error. Please help me get it working correctly.

Tushar
mschering
Site Admin
Site Admin
Posts: 8333
Joined: Tue Apr 20, 2004 1:06 pm
Location: The Netherlands - Den Bosch
Contact:

Re: JsonStore load exception error in Modules

Postby mschering » Mon Dec 15, 2014 8:50 am

Check the error.log file in the group-office files directory for errors.
Best regards,

Merijn Schering
Intermesh
john3v
Posts: 41
Joined: Wed Nov 28, 2012 2:53 pm

Re: JsonStore load exception error in Modules

Postby john3v » Fri Jan 09, 2015 9:31 am

I have same problem after upgrade to 6.11.1/6.11.13

When I press "delete" for any task (in Tasks module) i have that message.

Log:
PHP Fatal error: Call to undefined method GO\Base\View\JsonView::renderload() in /usr/share/groupoffice/go/base/view/JsonView.php on line 10
User: admin Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Dragon/36.1.1.21 Chrome/36.0.1985.97 Safari/537.36 IP: 10.0.0.1
Query: r=export/load&security_token=Cq2Bj4NQrdZW9GleKfh6
Backtrace:
GO::shutdown in file unknown on line unknown
Eleazar
Posts: 4
Joined: Sat Jan 10, 2015 7:23 pm

Re: JsonStore load exception error in Modules

Postby Eleazar » Sat Jan 10, 2015 10:05 pm

I have this error when i try delete task https://www.group-office.com/forum/view ... 376#p35376
john3v
Posts: 41
Joined: Wed Nov 28, 2012 2:53 pm

Re: JsonStore load exception error in Modules

Postby john3v » Tue Jan 13, 2015 11:23 am

After "delete" on some task again I receive Json blabla
error log:
[20150109 10:39:33] PHP Fatal error: Call to undefined method GO\Base\View\JsonView::renderload() in /usr/share/groupoffice/go/base/view/JsonView.php on line 10
User: admin Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Dragon/36.1.1.21 Chrome/36.0.1985.97 Safari/537.36 IP: 10.0.0.1
Query: r=export/load&security_token=Cq2Bj4NQrdZW9GleKfh6
Backtrace:
GO::shutdown in file unknown on line unknown
same error after update to 6.1.14
fischli
Posts: 36
Joined: Tue Apr 22, 2014 10:06 am

Re: JsonStore load exception error in Modules

Postby fischli » Tue Jan 13, 2015 11:47 am

There is already a support ticket to this bug. If you are using the pro version of group-office, you are still able to delete tasks. This bug will trigger on the community version only (without ioncube loader).

Bugreport on sf
https://sourceforge.net/p/group-office/bugs/1629/
mschering
Site Admin
Site Admin
Posts: 8333
Joined: Tue Apr 20, 2004 1:06 pm
Location: The Netherlands - Den Bosch
Contact:

Re: JsonStore load exception error in Modules

Postby mschering » Mon Feb 09, 2015 7:41 pm

This has been fixed a while ago.
Best regards,

Merijn Schering
Intermesh
zefat
Posts: 1
Joined: Mon Feb 16, 2015 2:59 pm

Re: JsonStore load exception error in Modules

Postby zefat » Mon Feb 16, 2015 3:01 pm

@Merijn.

I still have the isseu of "JsonStore load exception occurred" when loading "Module".

This was on a PHP 5.3 and now also on a PHP 5.4 server.

Where does this error come from and how to fix it ?

Regards,

bert
mschering
Site Admin
Site Admin
Posts: 8333
Joined: Tue Apr 20, 2004 1:06 pm
Location: The Netherlands - Den Bosch
Contact:

Re: JsonStore load exception error in Modules

Postby mschering » Fri Feb 20, 2015 9:53 am

This JsonStore load exception error can be anything. You need to look at the log file for the detailed error and post it here. Or perhaps in a new topic.
Best regards,

Merijn Schering
Intermesh
john3v
Posts: 41
Joined: Wed Nov 28, 2012 2:53 pm

Re: JsonStore load exception error in Modules

Postby john3v » Thu Feb 26, 2015 8:29 am

Update:
updated to ver 6.1.16 and problem still exist
JsonStore load exception occurred
After I press "Delete" on some task.

At error log - nothning :shock:
mschering
Site Admin
Site Admin
Posts: 8333
Joined: Tue Apr 20, 2004 1:06 pm
Location: The Netherlands - Den Bosch
Contact:

Re: JsonStore load exception error in Modules

Postby mschering » Sun Mar 01, 2015 4:21 pm

Why 6.1.16? As 6.1.22 is out?
Best regards,

Merijn Schering
Intermesh
john3v
Posts: 41
Joined: Wed Nov 28, 2012 2:53 pm

Re: JsonStore load exception error in Modules

Postby john3v » Wed Mar 04, 2015 11:45 am

I wondered too.
But what I read in /etc/apt/sources.list after upgrade to trusty.
# deb http://repos.groupoffice.eu/ sixone main # disabled after upgrade to trusty
And now after editing that row, I have new version of G.O. 6.1.23 with no problems as described earlier.
Thanks!
jamesnw
Posts: 5
Joined: Sat Sep 26, 2009 2:54 am

Re: JsonStore load exception error in Modules

Postby jamesnw » Tue Feb 05, 2019 2:39 am

I got the same error:
An error occurred on the webserver. Contact your system administrator and supply the detailed error.
JsonStore load exception occurred
For those looking to install the latest version og Group Office, including PHP 7, on a Windows PC, the solution for me was to:

1. View the error log (under {files loc}/log/debug.log), and notice this line:
[158ms][go\core\ErrorHandler:69] Error in C:\inetpub\wwwroot\...\go\core\fs\File.php at line 210: Call to undefined function go\core\fs\mime_content_type()
(debugging must be enabled in config.php first)

2. Edit PHP.ini and add the missing extension: "extension=php_fileinfo.dll" in the [ExtensionList] section.
jhsdurham
Posts: 73
Joined: Sun Sep 15, 2013 4:04 am

Re: JsonStore load exception error in Modules

Postby jhsdurham » Sat Nov 09, 2019 4:08 pm

Wow! I spent hours looking for clues last night after upgrading from 6.2.122 to 6.3.84 and kept getting that error in the debug log. I had no idea how to fix it. I will try this tonight, thank you James. If this works, this should be a pinned post or something. I only found this by way of a Google search for the error message I was seeing, not from a search of the forums.

UPDATE
Well that certainly did resolve the problem with the Modules tab not working / reporting that json error in 6.3.84 but I still hit the big problem of the login screen being blank unless I turn Debug mode on. So this is an important solution, but not the only part needed to fix whatever it wrong with 6.3 yet. Thanks for this great lead.

Who is online

Users browsing this forum: No registered users and 4 guests

cron