how to install group office in qmail

Having trouble installing Group-Office? No worries. Help is on the way.

Moderator: Developers

how to install group office in qmail

Postby jyotirmay » Sun Jun 06, 2010 11:23 am

Hi,

I am having a qmail mailing system, I want to install the group office for end user web interface.

Kindly give me the procedure to install & configure the same

Waiting for your help.

Regards,
Jyotirmay
jyotirmay
 
Posts: 6
Joined: Sun Jun 06, 2010 11:13 am

Re: how to install group office in qmail

Postby webwolfi » Sun Jun 06, 2010 9:22 pm

GO is independant from the mailserver you are running.
It works fine with qmail. only to create mail accounts you have to use something like qmailadmin
webwolfi
 
Posts: 583
Joined: Sat May 27, 2006 7:54 am
Location: Vienna/Austria

Re: how to install group office in qmail

Postby jyotirmay » Mon Jun 07, 2010 7:46 am

Thanks for your reply.
Just now I have installed -groupoffice 3.5.5. I can now login with admin user,but I am unable to login with the existing users. It's showing the error Wrong username or password.

I think I am missing somewhere in the configuration. Please help me to configure the same.
jyotirmay
 
Posts: 6
Joined: Sun Jun 06, 2010 11:13 am

Re: how to install group office in qmail

Postby mschering » Tue Jun 08, 2010 3:33 pm

Are you sure you enter the right passwords? What if you change them.
Best regards,

Merijn Schering
Intermesh
User avatar
mschering
Site Admin
 
Posts: 7721
Joined: Tue Apr 20, 2004 1:06 pm
Location: The Netherlands - Den Bosch

Re: how to install group office in qmail

Postby webwolfi » Tue Jun 08, 2010 8:28 pm

hmmmmm... maybe you want to authenticate by imap account username and password

have look at this document:
http://www.group-office.com/wiki/IMAP_o ... entication
webwolfi
 
Posts: 583
Joined: Sat May 27, 2006 7:54 am
Location: Vienna/Austria

Re: how to install group office in qmail

Postby jyotirmay » Wed Jun 23, 2010 9:14 am

Hi...

Thanks for your reply I have configured imapauth. Now I can only able to log in with the admin user which was created at the time of installation pf Group Office, but unable to login with other user ID of my domain


My imapauth.config.php looks like this..
array(
'proto' => 'imap',
'domains' => 'mydomain.com',
'host' => 'localhost',
'port' => '143',
'ssl' => false,
'novalidate_cert' => false,
'mbroot' => 'INBOX',
'remove_domain_from_username' => false,
'create_email_account' => true,
'groups' => array('Internal'),
'visible_groups' => array('Everyone', 'Internal'),
'modules_read' => array('email', 'files', 'addressbook', 'calendar', 'tasks', 'notes', 'summary'),
'modules_write' => array(),

'smtp_host'=>'localhost',
'smtp_port'=>'25',
'smtp_encryption'=>'',
'smtp_username'=>'postmaster@mydomain.com',
'smtp_password'=>'password',

'ldap_use_email_as_imap_username'=>false
);


Kindly advice what can i do in this position.

Regards,
Jyotirmay
jyotirmay
 
Posts: 6
Joined: Sun Jun 06, 2010 11:13 am

Re: how to install group office in qmail

Postby mschering » Thu Jun 24, 2010 3:23 pm

Please enable $config['debug']=true; and look at /home/groupoffice/debug.log to see what happens.
Best regards,

Merijn Schering
Intermesh
User avatar
mschering
Site Admin
 
Posts: 7721
Joined: Tue Apr 20, 2004 1:06 pm
Location: The Netherlands - Den Bosch

Re: how to install group office in qmail

Postby jyotirmay » Fri Jun 25, 2010 4:40 am

Hi,

Please have a look at the log report...
Firing listener: ldapauth::before_login
LDAPAUTH: module is installed but not configured
Firing listener: blacklist::bad_login
Wrong password entered for jjena@mydomain.com
Login attempt for disabled user jjena@mydomain.com
Performed 4 database queries
Page load took: 3.0366830825806ms
Peak memory usage:6.78MB


But my qmail vuserinfo files looks like this.

name: jjena
passwd: $1$PXkohzAY$IsP5.h35KiORqxUp49v/b.
clear passwd: password
comment/gecos: jjena
uid: 0
gid: 0
flags: 0
gecos: jjena
limits: No user limits set.
dir: /home/vpopmail/domains/mydomain.com/jjena
quota: 41943040S
usage: 0%
last auth: Wed Jun 23 05:15:28 2010
last auth ip: imap



My go_users tables showing only my admin user

Please suggest.

Regards,
Jyotirmay
jyotirmay
 
Posts: 6
Joined: Sun Jun 06, 2010 11:13 am

Re: how to install group office in qmail

Postby jyotirmay » Fri Jun 25, 2010 10:14 am

Pls help...........
jyotirmay
 
Posts: 6
Joined: Sun Jun 06, 2010 11:13 am

Re: how to install group office in qmail

Postby dkittell » Tue Jun 29, 2010 2:33 pm

Do you have a test account or server that I could look at?
David Kittell
Owner / Developer
Kittell.net
User avatar
dkittell
Site Admin
 
Posts: 808
Joined: Tue May 25, 2004 10:32 pm
Location: Michigan, USA

Re: how to install group office in qmail

Postby mschering » Sat Jul 03, 2010 8:51 am

You showed us an imapauth configuration but I can tell from the message "LDAPAUTH: module is installed but not configured" you're using ldapauth. Please uninstall the ldapauth module and install the imapauth module.
Best regards,

Merijn Schering
Intermesh
User avatar
mschering
Site Admin
 
Posts: 7721
Joined: Tue Apr 20, 2004 1:06 pm
Location: The Netherlands - Den Bosch

Re: how to install group office in qmail

Postby jyotirmay » Mon Jul 05, 2010 7:35 am

Thanks a lot...This works for me
jyotirmay
 
Posts: 6
Joined: Sun Jun 06, 2010 11:13 am


Return to Installation

Who is online

Users browsing this forum: No registered users and 2 guests