Login problem - with no error message

Get help from the community here.

Moderator: Developers

EducationIT
Posts: 6
Joined: Thu May 12, 2011 11:46 am

Login problem - with no error message

Postby EducationIT » Wed Jun 13, 2012 10:23 am

Hello, we appear to be having issues with a couple of our accounts where the username/password are both correct but not logging the user in. It does not present an error message either.
We tried unticking enable and then re-enabling the account which appeared to have worked yesterday, but not working today.

The accounts are created in GroupOffice and using local authentication i.e. no ldap/imap, have reset passwords with no avail.

Please can you advise
mschering
Site Admin
Site Admin
Posts: 8357
Joined: Tue Apr 20, 2004 1:06 pm
Location: The Netherlands - Den Bosch
Contact:

Re: Login problem - with no error message

Postby mschering » Tue Jun 26, 2012 8:07 am

Try turning on debugging and see what happens in the log file.

$config['debug']=true;
Best regards,

Merijn Schering
Intermesh
ajsidike
Posts: 10
Joined: Fri Apr 30, 2010 10:27 am

Re: Login problem - with no error message

Postby ajsidike » Thu Sep 27, 2012 1:18 pm

What kind of system works and then stops working....and I've paid for it. Twice I've had to recreate my account in groupoffice because of some unknown bug in the system decides that my account is no longer valid. I go to log on with my usual name and password and I get nothing. I cant possible be the only person who is having this issue. Where is the support I pay for????? Log files?????? How many people do you know host their own webservers to use with group office...get real. I want the issue resolved or at least identified or my recommendations will be the people go elsewhere for the groupware.
mschering
Site Admin
Site Admin
Posts: 8357
Joined: Tue Apr 20, 2004 1:06 pm
Location: The Netherlands - Den Bosch
Contact:

Re: Login problem - with no error message

Postby mschering » Mon Oct 01, 2012 2:19 pm

Have you reported your problem to us?

How can we help you if this message is the first?
Best regards,

Merijn Schering
Intermesh
Lievaight83
Posts: 16
Joined: Sun May 19, 2013 7:42 pm

Re: Login problem - with no error message

Postby Lievaight83 » Sun May 19, 2013 7:47 pm

I seem to have the same problem. After 4 days of using it succesfully (with the occasional "JSONStore load exception error" message), it stopped working completely. If I check my error log, the last lines say

Code: Select all

[14-May-2013 20:11:20 Europe/Paris] PHP Warning:  sprintf() [<a href='function.sprintf'>function.sprintf</a>]: Too few arguments in /home/user/public_html/groupoffice-com-4.1.65/go/base/util/date/RecurrencePattern.php on line 464
[14-May-2013 20:11:25 Europe/Paris] PHP Warning:  sprintf() [<a href='function.sprintf'>function.sprintf</a>]: Too few arguments in /home/user/public_html/groupoffice-com-4.1.65/go/base/util/date/RecurrencePattern.php on line 464
[14-May-2013 20:11:35 Europe/Paris] PHP Warning:  sprintf() [<a href='function.sprintf'>function.sprintf</a>]: Too few arguments in /home/user/public_html/groupoffice-com-4.1.65/go/base/util/date/RecurrencePattern.php on line 464
[18-May-2013 18:17:04 Europe/Paris] PHP Notice:  Undefined index: id in /home/user/public_html/groupoffice-com-4.1.65/modules/addressbook/controller/ContactController.php on line 96
I've turned on debug mode, but nothing's happening, are there additional logs now?
For now, I can't login as admin or user, login page just reloads.

Apache version 2.2.23
PHP version 5.3.21
MySQL version 5.1.68-cll
Architecture x86_64
Operating system CloudLinux 5/6
groupoffice-com-4.1.65
mschering
Site Admin
Site Admin
Posts: 8357
Joined: Tue Apr 20, 2004 1:06 pm
Location: The Netherlands - Den Bosch
Contact:

Re: Login problem - with no error message

Postby mschering » Sun May 19, 2013 8:56 pm

This usually happens when GO can't create a PHP session. This can happen when the disk is full or PHP sessions a remisconfigured. Are you sure there are no errors in /var/log/apache2/error.log (or wherever the apache errors go)?
Best regards,

Merijn Schering
Intermesh
Lievaight83
Posts: 16
Joined: Sun May 19, 2013 7:42 pm

Re: Login problem - with no error message

Postby Lievaight83 » Sun May 19, 2013 9:51 pm

Hmm, well I installed GO on a shared hosting account. I've still got plenty of space, the error log I have access to shows nothing about php or GO (only a couple unrelated 404s).

Here's the PHP setup for my account

Image

I realise having no root access is a bit of a bummer, but I was just on the lookout for an alternative to horde. I really like GO, and if I could get it to work, that would be awesome.

EDIT 20/05 8 am: And now everything works again. I'm starting to think maybe it''s a memory-issue? Maybe my shared hosting account doesn't allocate enough of the memorey GO needs? I looked, but couldn't find hardware system requirements for GO.
mschering
Site Admin
Site Admin
Posts: 8357
Joined: Tue Apr 20, 2004 1:06 pm
Location: The Netherlands - Den Bosch
Contact:

Re: Login problem - with no error message

Postby mschering » Mon May 20, 2013 9:21 am

I've no idea. There should be errors somewhere. If no error is displayed then it should be logged somewhere.
Best regards,

Merijn Schering
Intermesh
saboor

Re: Login problem - with no error message

Postby saboor » Mon Apr 13, 2015 5:10 am

But now here a feature request regarding this issue. It would be nicer if the theme would automatically look for a menu button for all active modules without the need to add them in images.inc.

Reasoning: I'm sure as time goes by more and more 3rd party modules are going to come out. At the same time I'm sure more themes will also come out. If the user has to make changes to all the themes for every modules he/she installs this would be difficult.
mschering
Site Admin
Site Admin
Posts: 8357
Joined: Tue Apr 20, 2004 1:06 pm
Location: The Netherlands - Den Bosch
Contact:

Re: Login problem - with no error message

Postby mschering » Fri May 01, 2015 6:56 am

It will look in the default theme if it doesn't exist in the new theme.
Best regards,

Merijn Schering
Intermesh

Who is online

Users browsing this forum: No registered users and 8 guests

cron